SaaS CMS has officially launched! Learn more now.

Community Search not getting anything


I've set up a new Relate+ site. I created a user named user1.

I then tried searching user1 from the search bar on top but I didn't get any results.

Do I need to configure anything first before the search functionality starts to work?


Jul 20, 2011 3:10

You shouldn't need to do anything if it's a standard Relate site. Have you tried creating a blog and search for that? 

Jul 20, 2011 4:48

Haven't yet. I'll try it later. Thanks.

Jul 20, 2011 6:51

I've just created a blog which I could use for testing the search functionality. And right on the Search button, I searched for test, freedom, countrymen and it just doesn't produce any results.

You can test it yourself if you must.

It doesn't work for some reason and I have no idea why because this is a default install.

Edited, Jul 29, 2011 3:50

I suggest you enable EPiServer error logging and check the log file. You will see the search service requests produced. I assume you have the search service installed in the same application in which case you should see requests to /IndexingService/IndexingService.svc (you might have to enable logging at the debug level)

You can try to browse to /IndexingService/IndexingService.svc where you should see a WCF service "endpoint not found" message. If that works, try to browse to the URL found in the log (/IndexingService/IndexingService.svc followed by some more or less long querystring). That can give more clues to what is wrong. It should return an atom document (xml).

Jul 29, 2011 11:17
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.