Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

..ptx files open as .zip files

Vote:
 

My client has a problem with opening .pptx files (v.2010). They opens as .zip files. I have found information about this same problem regarding v.2007 files. But that is not the problem here. .pptx files in 2007 format opens fine. I have tried to change the mime-types, but that doesnt help. It works fine in firefox, but not in IE 8. (the client is restricted to use IE 8).

The site is running on Episerver CMS 4, but is going to upgrade to CMS 6 in a short while. Is it possible that this will be fixed when they upgrade their CMS?  

 

#58469
Apr 26, 2012 10:08
Vote:
 

If adding the MIME types don't help, you may have to install the MS Office Compatibility Pack on your server. Read more about it in this blog post:

http://www.epinova.no/en/blog/Lars-Oyvind-Bodahl/dates/2009/12/office-2007-files-behaves-as-compressed-folder/

#58552
Apr 30, 2012 10:53
Vote:
 

Thank you for your answer! I was hpoing not to install that compability pack. Office is not installed on the server. Do I then have to install Office aswell? 

Is it a chance that this will be easier when the CMS is upgraded to CMS 6?

#58715
May 02, 2012 12:16
Vote:
 

No, you don't have to install Office on the server, just the compatibility pack.

This is likely a server problem and not something that will be fixed by upgrading EPiServer CMS. 

You can also add the MIME-types programatically, as stated in this blog comment: http://www.epinova.no/en/blog/Lars-Oyvind-Bodahl/dates/2009/12/office-2007-files-behaves-as-compressed-folder/#comment516 but that would not be my first choice because you'd need to recompile and redeploy if there are any changes to the MIME mapping.

#58717
Edited, May 02, 2012 12:42
Vote:
 

If this is an environment where all the users are restricted to the same IE version, you could get the network admin to roll out a setting which forces IE to use default MIME handling instead of trying to detect the file type:

http://247pearsoned.custhelp.com/app/answers/detail/a_id/7836/~/internet-explorer-7-or-8%3A-office-2007-or-2010-files-saving-as-zip-files

#58719
May 02, 2012 12:49
Vote:
 

Thank you so much for the help. Then I will ask them to try to roll out the setting in IE before we try to install the Office Compatibility pack.

#58720
May 02, 2012 12:55
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.