Try our conversational search powered by Generative AI!

Scheduled Job not showing in the admin UI


Anyone have an issue where a class deriving from JobBase doesn't appear in the UI? The class is in a referenced DLL from another project. The strange part is that is shows locally for me, but not on the remote dev server which has a different database.

I have a current work around that creates a new class deriving JobBase and just calls the execute function of the job that doesn't appear in the UI which works, but I would rather not have to keep the wrapper.



Mar 04, 2015 17:51


JobBase is for scheduled job which supports stop. TO make it appears in admin UI, you need this attribute:

DisplayName = "Incremental Search Index Job",
Description = "This job indexs incrementally",
LanguagePath = "/Commerce/scheduledjobs/incrementalsearchindexjob")]



Mar 05, 2015 7:48

Hi Quan,

The class does have it, which is why I am stumped. Below is the attribute used:

DisplayName = "[HubSpot] Blog Import",
DefaultEnabled = false,
InitialTime = "1.1:0:0",
IntervalLength = 1,
SortIndex = 0,
IntervalType = ScheduledIntervalType.Days)]

public class ImportJob : JobBase



Mar 05, 2015 15:21

Is there a chance that your scheduled job is disabled?

Can you try with this:

SELECT @JobID = pkID FROM dbo.tblPlugIn
AND TypeName = '<your-job-class-type-with-namespace'
EXECUTE netPlugInSave @PlugInID = @JobID, @Enabled = 1


Mar 05, 2015 15:34

That was the issue. Thanks!

Mar 05, 2015 15:46

Hi, adding my 2 cents here too as I had the similiar "issue".

As we can see in Brads code he has the "DefaultEnabled=false" => the job is not enabled. I had this set too but on purpose as I assumed it would be mapped to the admin UI Active property of a job but as it turns out it actually is mapped to the job enabled property which means that when false it will not be displayed in scheduled jobs listing.

I think the easier and supported way of fixing the enabled or not in the Admin UI is to go to the Config tab in Admin mode -> Plug-in manager (under the tool settings) -> From the Plug-Ins list find your assembly that has the job and click it -> Switch to the overview tab -> Check the enabled checkbox for the job and hit Save.

Apr 08, 2015 9:10

Or you can use this guy: :) Should enlist all jobs, even those that never have been started or registered as disabled (scheduled plugin instance not saved.)

Apr 08, 2015 21:59
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.