Try our conversational search powered by Generative AI!

Creating a new environment


Hi, there,

I inherited a project that works well when the website uses the domain

I would like to change this so that I can develop from http://localhost:7001

So I made a copy of the database, and I tried to change this value in the Site Configuration area. For some reason that wouldn't take, so I made a change directly in the database, changing EPiServer.Web.HostDefinition's value in tblBigTable.

So I can start the project, but the rest of the site seems flacky. The one problem that I have been running into is that I can't access the Cms area to make edits.

What are the proper changes that I should do so that I can change the expected host and for the site to behave correctly?

Sep 16, 2015 22:45

What version of the CMS are you working on? I am guessing you like to run you solutoin on IIS Express and not the ordinary IIS.

This change has actually nothing or at least not much with the database of EPiServer. First you should almost neverver ever do any changes directly into the database. 

If your are using a version of CMS, 7.5 or above, you can sett host binding inside episerver admin interface, the website settings area. If you are using an older version of episerver you have an episerver.config or a section of web.config for episerver.config. In this section you can find a siteurl property. 

You need to set these propertys or fix these settings. I also sugest you change your csproj-file, properties, to use IIS Express and also change tha startup url for the project to the prefered adress and port.

Oct 05, 2015 22:49

I am using CMS 7.5. Yes, I tried using the UI, but that didn't work. The change wouldn't take for some reason. So I had to hack it directly via the db.

I had already set it to use IIS Express, and the start up page runs. I was able to access the CMS area by changing the web.config. As the other question that I posted says, I can see the CMS admin area, but I cannot see the pages yet.

I suspect that EPI still doesn't recognize my role and that is what is preventing the tree to show.

Oct 06, 2015 18:28
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.