Try our conversational search powered by Generative AI!

CMS 6: Moving site from one server to another


I'm trying to move a CMS 6 site from one server to another but keep getting the same "Object reference not set to an instance of an object." error. The stack trace seems to indicate that EPiServer is at least called. Was some 6 years ago since I last installed a CMS 6 site and I feel a bit rusty on the proper procedure.

The steps I've taken is as follows:

Backuped and restored the database.
Moved all the application files.
Backuped the VPP but not moved it to the new server yet since I'm on a bad connection most of the time.
Exported the IIS settings from the old server and imported them to the new one.
Tried to fix the security settings so that IIS can access to site. Seems working since the error is mentioning EPiServer.

This is the stack trace I'm getting:

[NullReferenceException: Object reference not set to an instance of an object.]
EPiServer.Web.UrlRewriteModule.HttpUrlRewriteToInternal(UrlBuilder url) +316
EPiServer.Web.UrlRewriteModuleBase.BeginRequestEventHandler(Object sender, EventArgs e) +203
System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +79
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +170

Anyone maybe have some idea of what I can do to debug this anymore? I'm kinda stuck..

Nov 13, 2016 18:49

Check on site settings in web.config and make sure the urls/domain etc are valid. In Epi 6 these are still stored in config files. 

Also need to install EPiServer on server through deployment center for older versions like 6 or edit mode will give 404

Nov 13, 2016 20:13

EPiServer is installed. It's hosted by EPiServer Hosting so they set up that part for us. You mean the urls for VPP, database and things like that? As I said, I haven't uploaded the VPP to the server yet (over 9 gb over bad connection and even worse VPN isn't fun) and the mentioned urls seems to be correct. Feels like the site don't event try to build. This error is showing really fast. No loading time what so ever.

Nov 13, 2016 21:12

Correct .NET framework version installed on the server?

Correct .NET framework version set up for your application pool?

Using  the UrlRewrite module for IIS? ..Is that installed on the server?

Nov 13, 2016 23:58

Turn on log4net on info level as well. 

Nov 14, 2016 7:04

We had a similar problem everytime we needed to get a project up and running in a new enviroment. It was an event attached to the urlrwrite (or something similar), and if we removed that piece of code, the site started. Then we could add the code back and everything worked. We never really knew what the actual problem was, but it might be worth to see if you have something similar...

Nov 14, 2016 8:56
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.