Issue with EPiServer NuGet Feed in Visual Studio


Hi All,

I'm at a bit of a loose end here so I'm wondering if anyone had experience or some good troubleshooting tips to help me out.

About 1.5 - 2 months ago I lost the ability to update EPiServer packages via Package Manager Console in Visual Studio Community v15.9.18 (ish) on Windows 10

Packages from work fine, but EPiServer packages not so much. 

I mostly get the following message:

" Failed to fetch results from V2 feed at ''EPiServer.Forms',Version='4.27.0')' with the following message: The HTTP request to 'GET'EPiServer.Forms',Version='4.27.0')' has timed out after 100000ms."

I say mostly because every now and again after a long wait, an EPiServer package with and update will either show in the 'Manage Packages for Solution' screen in VS or running the update-package command in the console will work.  

I can access the feed and the above uri via a browser and they load just fine. I've tried this both on and off my company network. I've been in touch with our IT and Service Desk and they haven't been able to help me. 

I've tried repairing VS, uninstalling completely and the reinstalling. No dice. I've googled quite a bit and done that thing where you read a suggested answer on StackOverflow and knowing full well it won't work, you try it anyway! ;)

Anyone ever seen this before?


Jan 06, 2020 17:29

Hi Alex

Are you running VS in administrator mode?

You said you have tried this both on and off my company network but have you tried with different system?

Have you checked %AppData%\NuGet\NuGet.Config for any possible issues?

Jan 08, 2020 12:41

Hi Naveed,

Yep I'm running in admin mode. I have tried on my personal laptop at home with same Win10 version and same VS version and it works fine there. So I'm thinking it must be something on my work machine and not necessarily VS!

I've deleted NuGet.config and re-entered the package sources to no avail. Then I 'installed' NuGet or rather enabled it globally by adding the path to the exe in my env variables and then tried updating and installing epi packages via the cli outside of VS and it worked perfectly. I don't understand that at all really.

I must have installed or updated something else which is conflicting with VS, but I have no idea what. I'll try cleaning up my machine and seeing if I get anywhere that way.

Thanks for your post. :)


Jan 08, 2020 12:51
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.