SaaS CMS has officially launched! Learn more now.

Scheduled Jobs missing after migration to CMS 12

Vote:
 

I am in the midst of migrating our CMS 11.14 to the latest CMS 12

As I am familiarizing myself with the new Admin UI, I noticed that there are nothing list under Scheduled Jobs, despite numerout in our database.  I can see them when looking in Config > Plug-in Manager > Scheduler Job Administration.

Any insight or help would be greatly appreciated!

-Kevin

#294019
Jan 02, 2023 18:03
Vote:
 

In my case I had to remove all rows from the table tblPlugIn. With that said, I thought that Episerver would've solved that specific issue with this fix: https://world.optimizely.com/documentation/Release-Notes/ReleaseNote/?releaseNoteId=CMS-22398

Anyway, run something like

SELECT * 
INTO tmpTblPlugIn
FROM tblPlugIn

DELETE FROM tblPlugIn

... and see if it works. Make sure you re-run the application so that you don't run into caching issues.

Edit: I did have the exact same issue, and if clearing tblPlugIn isn't enough - you could also check if you have any no longer existing scheduled jobs in tblScheduledItem. If a scheduled job is in the database but not in code, that could be a potential issue.

#294055
Edited, Jan 03, 2023 8:35
Vote:
 

I had the same issue, and my solution was (as Andreas') to remove a couple of lines from tblPlugin.

#294066
Jan 03, 2023 19:49
Vote:
 

Thanks Andreas and Tomas. 

Despite my prior conclusion that your suggestion was not effective, I discovered that I was in fact editing in the wrong database! 😱

So I have edited this response to indicate success!

#294179
Edited, Jan 05, 2023 13:04
Dileep D - Jan 05, 2023 13:34
Not sure if it makes sense but I had my scheduled jobs page empty despite having entries in the database table. I was using CMS 12 running it from local IIS. I had to delete all the contents of the directory where the application was hosted and re-deployed and it did start to show. Visual studio option of removing old files during publish didn't work.
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.