Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Unable to create a ordinary page

Hi, I'm trying to deploy a episerver 4.61 websolution for a customer but they are not able to create any ordinary webpages. On existing pages there is only show flag and not the other flags as version control. What I mean by not able to create ordinarry webpage is that when you choose empty page the background is only showing without any textarea boxes and buttons. Only a gray area. I can confirm this because it fails for me as well. Since I'm not able to determin the error I have rebuild the hole solution by installing a new site from Episerver Manager and then put on bits and peaces, so now I have a working solution locally. I've tried to deploy it, but the problem is still there (on the customers server). It was working earlier this autumn and I have backups from this time, so I've tried to use earlier web.config files but nothing happens. I've downloaded their database locally and uses this in my development solution and it still works. I should think it was a security problem, however my account has administrative rights. This is a serios problem I can't see any solution for, my co-workers has looked at it, but can't see any errors.. Please - if you have any clue, please give me a hint! Kind regards, Jon Haakon
Nov 29, 2007 14:44
You might have a plug-in problem. The edit, version etc. tabs are loaded as plug-ins in EPiServer. It could be that the site fails during load. Check your global.asax file for code that could potentially fail. There could also be custom plug-ins on the site that prevents the built-in from loading. Verify that the 404 handler in IIS has been set up correctly. In Admin mode, there is a link for plugin configuration. Someone could have turned off something they should not have. It is worth a look. You could also try FileMon from System Internals to see if you get any Access Denied from withing the site directories on disk. If you have downloaded the files (.dll etc.) using IE from somewhere during a deployment, they could be "blocked". Right click each .dll and select Properties. Make sure you do not have an "Unblock" button on the lower left part of the Properties dialog. /Steve
Nov 30, 2007 8:03
What kind of plugins are we talking about here. There is no tags showing for creating a new page. "Show" is the only tab showing for created pages. Is the pluging's located in the Episerver.dll files? This is a plain 4.61 installation. Regarding global.asax I only find: <%@ Application Codebehind="Global.asax.cs" Inherits="EPiServerSample.Global" %> and in Global.asax.cs the only code worth mentioning is: protected void Application_Start(Object sender, EventArgs e) { EPiServerSample.Templates.Wsrp.Core.ProducerBaseSupport.InitializePortlets();} 404 handler is set up by default settings from IIS. Is this correct? I've traced filemon and can only see system.css under util that is not found. Some files get "buffer overflow", end of file messages and files that is not found. No "access denied". I've been looking through the config tab in Admin and can only find "Access control for functions" relevant to check out here. I've added myself on "All functions available in the editor" and "Detailed error messages for troubleshouting" (I have norwegian letters) so my translation can be bad. On side types I looked at "Edit tabs", but couldn't see what I should change. It was mostly read access there. "Change" for "Advanced" All files are deployed through MS Remote Desktop by copying files from Explorer. "Unblocked"? You mean the attribute "Read-only"? I can't see any unblocked byttons on the dll files. I have no clue in what is wrong here and now I am out of options on what to try out. Can I send you any code that can be relevant for finding the solution on my problem???
Nov 30, 2007 14:58
I've set up EPiServerLog.config and found that there was an authorization problem with LDAP, but that shouldn't have any consequences for creating a ordinary web page would it? Kind regards, Jon Haakon
Nov 30, 2007 15:54
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.