Try our conversational search powered by Generative AI!

Episerver Installation fails at database

I'm installing Episerver, offline using Episerver Manager The database is on another machine. When I try to see the users, or existing databases, it gives the error message: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server Connection. How can I progress? I am in a data centre and would love to get this setup done so I can get back to work! Martin
Jun 28, 2007 16:02
Hi. Make sure you're sql server is configured to work in mixed mode according to this FAQ: Regards Per
Jun 28, 2007 16:47
I have tried this. I have tried two separate databases and I made sure that mixed mode was enabled. Then I installed the database from script and just set up the connection string later. But the login to the admin does not work, and when I try to access the base site I get 'The Network Path Was Not Found' as a .net error.
Jul 15, 2007 19:53
I got a bit further. When I logged out and logged in again, I think the Admin user that I had created was able to write to event logs. So the network path not found error went away. Now it's the (standard) login problem. The system doesn't let me log in and doesn't give me any information. I've had this old problem so often! I've made sure that I'm using an Administrator user and I've made sure that the guest account is disabled. But still no joy :(
Jul 16, 2007 18:59
Apart from using mixed authentication mode, have you tried the following I found at I suggest trying all three suggestions to see which one is at fault in your setup. ...The Next step is to ensure that the ASPNET account (IIS_WPG in case of Windows server 2003) has the appropriate access to the Database. To do that, do the following steps: 1. Open SQL Server Enterprise Manager (Start - Programs - Microsoft SQL Server - Enterprise Manager), select the appropriate server, and expand the Security folder. 2. In the Logins check whether the IIS_WPG is listed. 3. If it is not listed, right-click on Logins and select New Login 4. In the Name: textbox either enter [Server/Domain Name]\IIS_WPG or click on the ellipses button to open the Windows NT user/group picker. 5. Select the current machine’s IIS_WPG group and click Add and OK to close the picker. 6. You then need to also set the default database and the permissions to access the database. To set the default database choose from the drop down list, 7. Next, click on the Database Access tab and specify the permissions. 8. Click on the Permit checkbox for every database that you wish to allow access to. You will also need to select database roles, checking db_owner will ensure your login has all necessary permissions to manage and use the selected database. 9. Click OK to exit the property dialog. Your ASP.NET application is now configured to support integrated SQL Server authentication. UGH!! I wasted a whole day on this problem. The solution was quite simple once I realized that the problem was not with my sql server permissions, but with the local IIS server settings on my .Net development machine. I had a suspicion that this might have to do with how IIS was attempting to connect to the sql server in question, but I didn’t have a clue as to where to go to change how it was submitting the login credentials. The answer was in the IIS manager by selecting the properties of the website in question (I used the Default Web Site), then selecting the ASP.NET tab in the website properties dialog. There are two buttons on the bottom of the tab screen one for global one for that particular web site node. I chose global, because I don’t want to do this more than once. At this point another dialog will pop up (ASP.NET Configuration Settings) with 7 tabs. Choose the “Application” tab. At the bottom of that tab screen there is a group called Identity settings. Make sure the Local impersonation checkbox is checked. Don’t put anything in the User name and Password if you want it to use your PC login credentials. Click OK all the way back and restart IIS. You should be golden. -->IF YOU ARE USING WINDOWS 2003 SERVER!!!!!<-- You must enable DTC access. By default it is not installed on Windows 2003 Server (all flavors). Step One: Steps to Enable Network DTC Access (Run on all machines requiring DTC access) 1. Click Start, point to Control Panel, and then click Add or Remove Programs. 2. Click Add/Remove Windows Components. 3. Select Application Server, and then click Details. 4. Select Enable network DTC access, and then click OK. 5. Click Next. 6. Click Finish. 7. Stop and then restart the Distributed Transaction Coordinator service. 8. Stop and then restart any resource manager services that participates in the distributed transaction (such as Microsoft SQL Server or Microsoft Message Queue Server). Best regards, Mats B.
Jul 16, 2007 21:18

We had the same problem here because the machine running the Episerver Manager (  in our case) - was not a member of the domain.

The machine running the manager was not in the domain but the machine hosting the sql server (2005) database was in the domain. The Administrator account on both machines had different passwords. (noted this in case it makes any difference) 

All the above didnt work for us - but adding the comptuer to the domain and theafter logging into the machine with a domain user that the sql server machine recognised worked perfectly - problem solved.

Hope this helps

Feb 06, 2009 15:04

Also - make sure you close and reopen your browser as some cache the site.  Even refreshing doesn't get rid of the cached code.  

And restart IIS.


Nov 26, 2010 15:16
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.