Try our conversational search powered by Generative AI!

Strange behaviours/errors when EpiServer website is opened using Visual Studio.

Hi all, After pouring through the forum posts for a couple of hours and not finding any such problems being reported earlier, i am posting them here. I installed Episerver cms 5 (with a developer licence) using CMS Manager. The installation was successful. However now i face few problems 1.) I opened the installed website from visual studio 2005( File -> open website-> local iis -> The Website shown in the solution explorer shows pseudo folders which actually donot exist in the file system. For ex: When i expand the "bin" folder in the soln explorer i find all the website folders/files (namely App_Browsers, App_Themes, Bin, images, properties, util, webservices, web.config etc)under it.Same is the case when i expand help, images,lang,templates, util nodes. When i expand any of them, i find all the contents of actual website under it. Is this a bug in Episerver or in Visual Studio 2005?? 2.) Unable to solve the above problem I deleted the virtual directory in the IIS and created a new virtual directory with the same old alias pointing to the original Episerver physical folder. This solved the problem but now the site does not work at all. After I successfully login, i see a page not found error. When i manually type the url i.e., http://localhost//default.aspx the page opens. Also the friendly url's no longer seem to work becoz http://localhost//en returns page not found error. 3.) When I build the newly installed website in VS 2005, i find these compilation errors. a.)Could not load type 'EPiServer.UI.Util.ExplorerTreeBranch'. util/explorertreebranch.aspx b.)Unknown server tag 'EPiServer:explorertree'. util/explorertreebranch.aspx I do not think it is due to missing references because a site installed using CMS manager is supposed to work without any modifications to it. Any help would be greatly appreciated! Thanks in advance, Harish.
Jan 07, 2008 14:33
You're opening the installed EPiServer site as an IIS Web Site project, which is not supported. Instead, after having installed it, open Visual Studio 2005, File, Open Project, and find the .csproj file in the root of the site you installed. Note! You must have SP1 installed for VS2005, as EPiServer is using the Web Application Project (WAP) model, which is much the same as the way things worked in VS 2003. /Steve
Jan 11, 2008 21:58
Hi Steve, Thank you. But I do not find any .csproj files apart from that of the Publictemplates.csproj. Is this the project file? Doesn't look so. Regards, Harish.
Jan 14, 2008 8:13
That is the correct file. Do you have SP1 of VS 2005 installed? /s
Jan 14, 2008 9:58
Hi Steve, I have tried opening the project after running the Web Application Projects Setup msi file. But i do not have SP1 installed. Will install the service pack first. Regards, Harish
Jan 16, 2008 10:56
Yes!! Installing SP1 did the trick. Thanks Steve.
Jan 18, 2008 8:16
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.