Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Indexing Service: Update batch could not be sent to service uri

Vote:
 

Hi,

For a website running EPiServer 7.5 Update 35 (7.14.0) we can't get the Indexing service to work.

When we check EPiServer's log files we see the following happen very often:

2016-09-14 04:13:28,012 [494] ERROR SearchSettings: Update batch could not be sent to service uri 'http://www.xxxxxx.com/IndexingService/IndexingService.svc/update/?accesskey=local'. Message: 'The operation has timed out   at System.Net.HttpWebRequest.GetResponse()
   at System.Net.HttpWebRequest.GetResponse()
   at EPiServer.Search.RequestHandler.MakeHttpRequest(String url, NamedIndexingServiceElement namedIndexingServiceElement, String method, Stream postData, Action`1 responseHandler)
   at EPiServer.Search.RequestHandler.SendRequest(SyndicationFeed feed, String namedIndexingService, Collection`1 ids)'
2016-09-14 04:13:28,018 [494] ERROR SearchSettings: Send batch for named index 'serviceName' failed. Items are left in queue.

Currently we have the following settings in the configuration file:



  
    ...
    
... ... ... ... ... ... ... ..

Currently we have the following EPiServer nuget packages installed:

  
  
  
  
  

I'm unsure what causes the Indexing service to not working. Does anyone know what could cause this?

Thanks in advance!

#155376
Sep 15, 2016 11:23
Vote:
 

1. Check that you added host url www.domain.com to map to 127.0.0.1 so that the request is local. (Host file is normally at C:\Windows\system32\drivers\etc)

2. Clear tblIndexRequestLog table and the index folder and rerun indexing. Hidden function at http://yoursite/EPiServer/CMS/Admin/IndexContent.aspx...

3. Try upgrading to latest nuget package for search

I would try the above and see if that helps...haven't had that exact error though

#155379
Edited, Sep 15, 2016 12:52
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.