Try our conversational search powered by Generative AI!

Simple address stopped working after libraries update


After I updated CMS from 12.5.0 to 12.9.3 I started getting 404 on pages with "Simple address" property filled wile trying to open the page by that link.

Also when I try to call ContentUrlResolver.Resolve(...) it returns null where previuously it all worked.

The weird part about that is when I go to CMS and edit some property and re-publish my page, the simple address starts working. By the same simple address. And ContentUrlResolver.Resolve(...) returns my content. But only for a couple of minutes. After some time passes, it's back to 404.

I assume that it's due to some of the new features or fixes but I don't understand the new setup and what new options represent:

Also I noticed that simple addresses are supposed to be single-segment now but we have only multi-segment ones.

Can anyone please explain how simple addresses are supposed to be used now?

And what new Setup.cs options do we have for simple addresses?

Dec 12, 2022 12:20

Have you tried go to latest CMS 12.15? Why stop at 12.9.3? 

Simple adress is a routing that happens before the normal routing i remmember correctly. With developer tools plugin you can check so you have that routing or by code and debugging. 

Dec 13, 2022 21:01

I didn't go to the latest EPiServer.CMS.Core 12.11 because of this feature:

It describes IList properties being introduced but we have those already implemented and had for 5+ years from CMS 11. And they worked fine until this. With update to 12.10+ app fails to start. I'm getting null reference exceptions with no message and only found out the reason by debugging decompiled code. It probably fails to migrate our existing IList properties. I'll create separate thread for this later.

I'll try to check routing with developer tools.

Still, it's not clear to me why it works for a couple of minutes after publish and then goes back to 404 again.

Edited, Dec 14, 2022 13:07

Luc, in dev tools I've checked routes that I have for that page and for SimpleAddress but don't see anything that would make mjy link work.

I've also checked before and after publishing the page (to make it work for short period of time) but no changes in routes.

Do you have insight on how to debug episerver routing and simple address logic? What is the entry point for that?

Dec 14, 2022 13:56

I would open a ticket with developer support

Dec 14, 2022 20:24
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.