Try our conversational search powered by Generative AI!

Handler "wildcard" has a bad module.


I've been running the Demo Version of EPiServer 6 on my local machine, which is running just fine. So I decided to give V7 a go as well.

After installing a new EPiServer 7 Site (Alloy demo included) on my local machine, which is running IIS 7.5. I am unable to browse to my CMS/UI path to access the Edit/Admin Modes. Whenever I try to do so I receive the following error:

HTTP Error 500.21 - Internal Server Error
Handler "wildcard" has a bad module "ManagedPipelineHandler" in its module list

Is there something I would need to in terms of configuring my IIS to fix this issue? (Or anything else)

Another issue is that when browsing to my localhost/portnumber which i've set up my site on, i only receive the "This installation only contains core files"-page, but as I've read here on the forums, it appears that I could just delete some default-pages to get rid of that issue. Just thought I'd mention it in case it could in any way be related to this issue.

Any ideas are appreciated. Thanks!

Nov 21, 2012 9:58

It sounds like this is just a slight variation on the rather common error in newly set up environments:

"PageHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list

(in your case it just ran into it on a different handler, I suppose), which suggests that there's probably something wrong with the IIS/ASP.NET4 environment. I believe this comes down to it being sensitive about the order in which different components of the system were installed.


You'll probably want to use the repair option for .NET Framework 4, ie something like:

%windir%\Microsoft.NET\Framework64\v4.0.30319\SetupCache\Client\setup.exe /repair /x86 /x64 /ia64 /parameterfolder Client

or if 32 bit:
%windir%\Microsoft.NET\Framework\v4.0.30319\SetupCache\Client\setup.exe /repair /x86 /x64 /ia64 /parameterfolder Client


See for instance:

Edited, Nov 21, 2012 10:22

That was it. Thank you Håkan! 

Nov 21, 2012 10:40

Can I have more details about this???

I have the same problem if I use Classic mode in Application pool. 

Thanks !! 

Apr 23, 2013 5:07
the folder


didn't exist on my install but

%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i

fixed the problem for me
Edited, Apr 23, 2013 14:10

I'm trying to assemble the box with Win2012 andf EPi7.5, and to solve this problem I had to install all .NET 4.5 options available in the "Features" selection for this server.


Probably there are only SOME options really required, but I haven't checked yet.

Aug 11, 2015 12:31
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.