Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

How do I set default language for a site?

Vote:
 

I have disabled globilization for a site and selected Swedish as the only active language in admin mode. In edit mode I have selected Swedish as the only language in the Root page language settings. But still the root page says 'Language: en'. 

I could not find a setting when installing the site to choose a specific default language. I even tried to manually change language branch in the database tables but then I could not start the site. 

Is there any way to change the language of the root page? Or is it not important at all, maybe it's enough to set the language on the start page?

My goal is to initially build a site in Swedish, and later on add English and perhaps some other language. 

#63485
Nov 20, 2012 16:28
Vote:
 

I have never botherd about rootpage for sites only startpage, have not had any problem with it either so far.. :). But you should also set the language in web.config uiculture and culture to swedish if that is the default language for the site.

#63489
Nov 20, 2012 22:06
Vote:
 

Thanks Eric, I suspect you are right, that I should just ignore the root page. But isn't it a bit strange, that you can't select a standard/default language when installing? Or at least change it after installation? 

Anyone that can verify this behaviour?

#63504
Nov 21, 2012 9:37
Vote:
 

I totaly agree or we ar just missing something but then again why so difficult to change default language :)

#63508
Nov 21, 2012 10:12
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.