SaaS CMS has officially launched! Learn more now.

How do I translate a page?

Vote:
 

I'm setting up an EPiServer 7 CMS site and I'm trying to figure out how the globalization works. I activate another language (e.g. 'suomi') exept from my default language 'svenska', and then I select a page in the page tree. When I try to switch language under 'Sites' to 'suomi', I get a yellow bar on top of page telling me I need to translate it to be able to edit the page. Problem is, there is a translate button next to the message, but it is disabled.

I installed an Alloy Template site next to my site, but there was the same problem. So it doesn't seem to be my configuration that is wrong.

Anyone have an idea why the button is disabled and how I can enable it?

#63405
Nov 19, 2012 13:54
Vote:
 

There are a couple of criteria that needs to be fulfilled in order for the translate button to be enabled. The one that I think is most common to forget is if the language is available for creation or not.

To see if it's enabled you need to access the language settings for the page you are trying to translate. You can access the language settings by going to the page in a language that already have a language version and going to forms editing on that page. In forms editing you will find a drop down button saying Tools where you will find the access to the language settings. It's the same place where you set replacement and fallback languages.

In the top option in the language settings you will need to enable the language for creation.

Try that and see if it helps.

#63411
Edited, Nov 19, 2012 16:20
Vote:
 

Thank you Nicklas! That helped! Why doesn't the manual say something about this? 

Follow up question: is it necessary to do this for every page on the site? Or is there a global settings? (Like, enable language for all pages below this page)

#63416
Nov 19, 2012 17:28
Vote:
 

I suspect it's only an oversight if the manual doesn't mention this. I'll notify the documentation team about it.

It's not necessary to set this on every page. If you go to the language settings for any page that is below the start page you will see that there is an additional checkbox saying: "Inherit settings from the parent page". That checkbox should be checked by default resulting in any settings set on the start page will also be valid for all descendants as long as no one fiddles with that checkbox.

#63436
Nov 20, 2012 8:20
Vote:
 

The language settings are described in the "Globalization" section of the EPiServer CMS User Guide here: http://webhelp.episerver.com/CMS/7.0/EN/Default.htm#Globalization/Edit_Globalization.htm.

This procedure hasn't really changed from CMS 6 R2, meaning that besides from activating a language in Admin, you also have to activate the language in Edit view, to allow editors to create content in that language.

#63437
Nov 20, 2012 8:29
Vote:
 

Thank you both Nicklas and Andrea. I read the editor & admin manuals as PDF which looks basically the same as the webhelp. 

What I didn't understand fully was:

2. The administrator enables the language to be active in edit mode under Language Settings.

I guess I confused it being a part of step 1 in the manual together with unexperience of globalization even i CMS 6. Also the new UI in Falcon confused me a lot, it was hard to find the language setting in edit mode. It was not clear either that it should be set on the start page to be enabled for all pages below. 

Maybe a more clear documentation on this would be a good thing?

#63441
Nov 20, 2012 10:09
Vote:
 

Thank you for your feedback Josef both on the UI and the documentation, will incorporate this in the work with the next version. 

#63445
Nov 20, 2012 11:00
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.