Try our conversational search powered by Generative AI!

Moved Site to New Folder and Now have ClientResources error


Is there a place i need to make a modification for this.  I moved the site to a different folder and now i get the following error.

[DirectoryNotFoundException: Could not find a part of the path 'S:\WWWROOT\Blend\LT\Website\ClientResources\ClientResources\packages.config'.]
   System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +224
   System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) +1352
   System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) +65
   System.Web.Hosting.MapPathBasedVirtualFile.Open() +75
   EPiServer.Shell.UI.Web.Resources.ClientResourcePackageLoader.LoadPackages() +104
   EPiServer.Shell.UI.Web.Resources.ShellPackageClientResourceProvider.LoadClientResources() +75
   System.Lazy`1.CreateValue() +416
   System.Lazy`1.LazyInitValue() +152
   System.Lazy`1.get_Value() +75
   EPiServer.Shell.UI.Web.Resources.ShellPackageClientResourceProvider.GetClientResources() +12
   EPiServer.Framework.Web.Resources.ClientResourceService.<.ctor>b__1(IClientResourceProvider p) +8
   System.Linq.<SelectManyIterator>d__14`2.MoveNext() +234
   System.Collections.Generic.List`1..ctor(IEnumerable`1 collection) +381
   System.Linq.Enumerable.ToList(IEnumerable`1 source) +58
   EPiServer.Framework.Web.Resources.ClientResourceService.<.ctor>b__0() +109
   System.Lazy`1.CreateValue() +416
   System.Lazy`1.LazyInitValue() +152
   System.Lazy`1.get_Value() +75

    Any help would be appreciated.

Nov 01, 2012 2:28

this happens now when i add this to the mvc template



Edited, Nov 01, 2012 2:36

Paths are configured in the virtualPathProviders section of EPiServerFramework.config and there's corresponding configuration for the module virtual path roots in the section of web.config.

Which actions did you perform in the move? I think a bit more information is required to figure out which additional steps are needed.


Nov 05, 2012 11:35

Could you check fololowing configuration option in EPiServerFramework.config?


<appData basePath="C:\EPiServer\VPP\SiteName" />


Does it contains correct base path for site VPPs folder?

Nov 05, 2012 12:23

Dmytro's solution fix the problem for me, thanks! I didn't notice that EPiServer tries to create the VPP (or AppData) folder if it does not exist.

Jan 25, 2013 12:45

Fixed my problem too

Feb 01, 2013 10:21

It didnt fix my problem :)

It happens when someone tries to login, and then every page is broken. I am hunting maybe for a episerver edit/admin part that fucks it up.

I copied all the missing stuff in the episerverframwork config from a working clean Epi7 project, the problem-project is an upgrade-project.

Is it just me that gets this problem?

Apr 08, 2013 9:47

Kristian, did you ever solve this? I have i similar error...

Apr 26, 2013 11:29

I think it is the basepath, because I suddenly got the same problem on a fresh project, now I use \\xx.xx.xx.xx\vpp\[Project Name], but I have to change to the physical path, or so I think. I am going back to this problem project next week, and I hope to fix it quick.

Apr 26, 2013 12:01

Did you find a solution for the problem project, Kristian?

Apr 30, 2013 12:49

Yeah, my module folder in the VPP Folder was empty, and after copying over the files and dlls from my devPC it started to work.

I figured it out because after fixing the basepath I could access all the site except edit/admin.

Apr 30, 2013 13:01

Thank you so much, it worked!

Made a new project and copied over the VPP folder to my projects appData path.

Note to anyone wondering: Also works with a relative path.

Apr 30, 2013 13:15

Just a note. I had this problem - the module folders were missing BUT i had to restart IIS before it worked. Puzzled me for half an hour or so

Mar 20, 2014 13:39

Make sure your web.config contains the following too (version 7.19):

<publicModules rootPath="~/modules/" autoDiscovery="Modules" />
<protectedModules rootPath="~/backoffice/">
<add name="Shell" />
<add name="CMS" />
Edited, Aug 27, 2015 12:14
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.