Try our conversational search powered by Generative AI!

Edit mode and Dashboard doesn't load after upgrade



We have upgraded an EPi6 R2 site to EPi7. After the upgrade the Edit Mode and the Dashboard does not load. The top menu is shown, but Add-Ons and Visitor groups are missing. There is no error message displayed on either of the pages. But when running the debugger there are a pop-up window showing:

Cannot connect to the webserver. What would you like to do? Try again/Cancel

Admin page works fine. I can access the old editor in localhost:XXXX/CMS/Edit/. From there I can edit and publish without problem. 

Looking in the scripts in the site there are 30+ errors in the script "dojo.js". The error messages is:

This operation requires IIS integrated pipeline mode.


GET http://localhost:33993/shell/Stores/profile/?dojo.preventCache=1357552131868 500 (Internal Server Error)

And others similar to the above containing dojo refrences.

The Application Pool is set with integrated pipeline and we have upgraded it from .NET 3.5 to .NET 4.0.

In this project we have used EPiMVP,, and therefor we need to use PageTypeBuilder. So we have used this customization:

I have seen some other posts about a similar problem when using IE 8. But this problem occurs in all browsers.

Has anyone else encountered a similar problem?



Jan 07, 2013 11:24

Does the other error message (the one referenced as only "500 (Internal Server Error)" above) say anything different or is it another case of the same error message? (If you have a look at the full response in eg Fiddler or the "Network" view of your browser's web debugging tools.)

Regarding request where you got "This operation requires IIS integrated pipeline mode.", what was requested? Was that from some different application? It sounds like something is not in integrated pipeline mode if that is happening.

Also, maybe double-check which application pool is used for the site and which pipeline mode that pool is set to.

Jan 07, 2013 13:16
The full respone is:

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
Exception Details: System.PlatformNotSupportedException: This operation requires IIS integrated pipeline mode.

Stack Trace:
[PlatformNotSupportedException: This operation requires IIS integrated pipeline mode.]
   System.Web.HttpResponse.get_Headers() +9681914
   System.Web.HttpResponseWrapper.get_Headers() +9
   EPiServer.Shell.Services.Rest.RestHttpHandler.ValidateAntiForgeryToken(HttpContextBase httpContext) +78
   EPiServer.Shell.Services.Rest.RestHttpHandler.ProcessRequest(HttpContextBase httpContext) +81
   EPiServer.Shell.Services.Rest.RestHttpHandler.ProcessRequest(HttpContext context) +42
   System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +341
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +69

There are 5 links causing the same error message, these are all XMLHttpRequests:



All the errors comes from the same application and I have checked that the Application Pool in use have Managed Pipeline Mode: Integrated.

Edited, Jan 07, 2013 13:41

Just to make sure, this happens with the site running in IIS (or IIS Express)? (Not the webdev/"cassini" server?)

Jan 07, 2013 15:03

This error occurs in both settings. Though, when running through IIS it takes very long for the page to be loaded. Often more than an hour. When doing so I get an error message in the log saying:

Update batch could not be sent to service uri 'http://myproject/IndexingService/IndexingService.svc/update/?accesskey=local'. Message: 'The operation has timed out at System.Net.HttpWebRequest.GetResponse()
at EPiServer.Search.RequestHandler.MakeHttpRequest(String url, NamedIndexingServiceElement namedIndexingServiceElement, String method, Stream postData, Action`1 responseHandler)
at EPiServer.Search.RequestHandler.SendRequest(SyndicationFeed feed, String namedIndexingService, Collection`1 ids)'

We have encountered this problem in other project, but never experienced this kind of problem then.

Jan 07, 2013 15:32

Webdev/"Cassini" is roughly IIS6-compatible (no integrated mode!) and is not supported for use with EPiServer 7.

You'll want to use IIS (7+) or IIS Express (which can be used as a more direct replacement to webdev in VS).


If you get "This operation requires IIS integrated pipeline mode." when running in IIS (with an app pool set to integrated mode), that is indeed very strange.

Jan 07, 2013 16:06

Ok. Thank you for the help.

After I stopped using Webdev/Cassini to troubleshoot the problem I found the troublemaker. It was the EPi7 licence file. After I downloaded a new licence it suddenly worked. (Not with webdev ofcourse)

Jan 09, 2013 13:31

Hi i have the same issue after upgrading to version 7

but we are using classic mode iis and can't quite move to integrated mode yet.

is it possible to run episerver 7 on iis7 running classic application pool ?

Jun 17, 2013 14:46

You need Integrated Pipeline mode.

Jun 17, 2013 15:17
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.