Try our conversational search powered by Generative AI!

Problems with Simple Address


For some reason, on the site that I'm developing, if I set a simple address for a page it gives a 404 Not Found. What makes this strange is that although simple addresses don't work on our CI or test servers, they  work just fine on my development environment. I've tried just about everything I can think of and nothing seems to help, and I've completely run out of ideas what could be causing the 404s.

The code is the same on all environments and it makes no difference whether the code is compiled to Debug or Release.
The dev and CI environments share a common database, so the problem is not some configuration that's stored in the DB.
I've gone through all .config files and there's no differences between them that could explain the issue.
On my dev environment I've tried both IIS and IIS Express and both work fine, so the reason isn't that servers are running IIS and the dev environment is usually running IIS Express.
On the CI environment there are other Episerver 7 sites and none of them have the same issue.

Any ideas what I could be missing here?

Mar 20, 2013 11:42

The problem with simple addresses seems to have been fixed with EPiServer 7 - Patch 2.

EDIT: It seems that Patch 2 didn't fix this. It must have just been a coincidence that the problem was fixed around the the same time as updating to Patch 2.

Edited, Mar 22, 2013 9:02

I have the same problem, but upgrading to Patch 2 did not solve it for me.


I'm really stumped, does anyone have any idea where I might look to find the solution?

Edited, Apr 16, 2013 10:04

Same problem here. 

Jun 04, 2013 22:55

Have it to, upgraded from EPi6

Jun 05, 2013 8:22

You could try to set strictLanguageRouting=false on configruation element element.

Jun 05, 2013 9:29

Hi, no that didn't solve this issue.

Jun 05, 2013 10:13

Have anyone solved this issue yet? Also have it. :(

Jun 12, 2013 0:35

Hmm, support said that you need a trailing slash in your siteUrl, didn't solve my problem though. But I noticed that I had added the simple address on a non master language page, and when I moved it to the master language, the simple address worked.

Jun 14, 2013 14:57

I've run into this problem again now with a different project and this time Patch 2 didn't help at all.

Jul 04, 2013 14:24

Any news on this? Shortcut links are only working for the main language on a site that we are currently working with. I tried installing patch #3 but unfortunately, this did not solve our problems.

Jul 05, 2013 12:52

Ok, so now I've found the solution to my problem. My siteHosts in episerverframework.config looked like this:

<siteHosts siteId="Customer.Web">
<add name="*" language="en" />
<add name="" language="en" />

when I changed it to this it started working.

<siteHosts siteId="Customer.Web">
<add name="*" />

But I guess you should be able to have it like the first config?


Sep 09, 2013 15:15

I can confirm that Erik's solution works for me too. Removing all other host mappings than <add name="*" language="fi" /> fixes the simple address handling for all languages, not just for the master language (in this case "fi"). I'm pretty sure simple addresses should work even if you define other hosts, since in a multi-site (enterprise) environment you have to be able to specify multiple hosts.

Sep 10, 2013 6:42

A little update on my previous post:

It's actually the language="fi" parameter that breaks the simple addresses.

This doesn't work:
<add name="*" language="fi" />
<add name="" language="fi" />

But this does work:
<add name="*" language="fi" />
<add name="" />

So try removing the language parameter and see if it makes any difference. I still think this is not intended behaviour, though.

Sep 10, 2013 15:30

Well, it's reported as a bug now: Bug #105507: Simple address problems with language 

Not verified yet though, but guess it's a matter of time.

Sep 11, 2013 15:56
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.