Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

XForms not working in blocks




I'm having some problem with getting XForms to work in a block. It's webforms and not MVC.

XForms works when I put them on a normal page, but when I use them on blocks I get a null exception. See below.


Exception Details: System.ArgumentNullException: Value cannot be null.
Parameter name: virtualPath

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[ArgumentNullException: Value cannot be null.
Parameter name: virtualPath]
   System.Web.VirtualPath.Create(String virtualPath, VirtualPathOptions options) +11615262
   EPiServer.Web.TemplateControlLoader.LoadControl(HttpContextBase httpContext, Type renderType, Object renderData, TemplateControl templateControl, String tag, Action`2 bindDataAction) +214
   EPiServer.Web.TemplateControlLoader.LoadControl(HttpContextBase httpContext, IContentData contentData, TemplateControl templateControl, String tag) +223
   EPiServer.Web.PropertyControls.ContentControlResolver.ResolveContentControls(ContentArea contentArea, Control parentControl, String tag, String itemCssClass, String itemTagName, Boolean enableEditFeatures) +604
   EPiServer.Web.PropertyControls.PropertyContentAreaControl.GetContentRenderers(Boolean enableEditFeatures) +598
   EPiServer.Web.PropertyControls.PropertyContentAreaControl.CreateContentAreaControls(Boolean enableEditFeatures) +130
   EPiServer.Web.PropertyControls.PropertyDataControl.CreateChildControls() +103
   System.Web.UI.Control.EnsureChildControls() +182
   EPiServer.Web.WebControls.Property.CreateChildControls() +600
   System.Web.UI.Control.EnsureChildControls() +182
   System.Web.UI.Control.PreRenderRecursiveInternal() +60
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4201


I tried to compare with the Alloy templates, but find no difference that should break it like this.

I also tried to debug, but it doesn't stop at any break points that could give any information.


Anyone know what the problem could be? Thankful for any help.

// Christopher

May 02, 2013 11:13

I found the solution to this problem, but not why the problem occured. My guess would be that episerver cached the renderer and try to access an older version of it that did not exist.

Solution was that the renderer for the block seemed to be corrupt in some way. What I did was to delete the webcontrol that was the renderer, enter edit mode and get the error "no renderer was found for block and then create it again.

So the problem the problem seems not to have been with the xforms module

May 06, 2013 10:56
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.