SaaS CMS has officially launched! Learn more now.

identical url segments for different pages with different languages

Vote:
 

In CMS 6 it was possible to create 2 different pages with different languages but with the same url segment:

page 1 (en-gb)
url segment: "my-page"
full url: /en-gb/my-page


page 2 (sv-se)
url segment: "my-page"
full url: /sv-se/my-page

In CMS 7 this doesn't work, either because of a bug or a design change.

When migrating from CMS 6 to 7 I had multiple pages with these settings. Now the swedish pages return "Felaktig länk". If I try to edit a swedish page, the url segment is changed to "my-page1" (not saved in the database until I publish)

So currently we have many pages that results in "Felaktig länk". Is it a bug or a design change? Any suggestions on how to proceed to fix this?

#71679
May 27, 2013 13:27
Vote:
 

That would be a bug.

Have you tried to apply the latest patch? There are some bugfixes done for routing.

Also I assume you do not have any host-language mappings done in episerverframework.config? Cause if you have a language mapping for the host then the language segment should not be part of the url.

#71725
May 27, 2013 15:39
Vote:
 

I'm using 7.1 with patch 2 (7.0.586.8)

No host language mappings.

If it's a bug, how do I get info on when it's going to be fixed?

#71727
May 27, 2013 15:56
Vote:
 

Hmm, I tried to reproduce the issue on RTM version (7.0.586.1) but there it works just fine. It works fine on our Maint branch (where the patches are built from) as well.

Do you have a custom Url rewrite provider?

I guess you also have a specified the prefix sv-se for swedish in admin mode (default segment for swedish is se).

#71728
May 27, 2013 16:34
Vote:
 

The language part of the URL works fine for all pages except the ones I mentioned.

Did you try to reproduce it on 7.1 with patch 2?

I just verified my first statement again. I'm not able to create 2 different pages, below the same parent with the same url segment ("Name i URL") and with different languages.

I'm not using a custom url rewrite provider

#71729
Edited, May 27, 2013 16:58
Vote:
 

Sorry I missed that it was two different pages. When I try that it works in our development branch (meaning it is fixed for next platform release), however in RTm and maint I get validation errors preventing me from saving the page.

#71730
May 27, 2013 17:01
Vote:
 

I have reported a bug for it now. 

#71731
May 27, 2013 17:02
Vote:
 

Do you have any info on when the next patch will be released? Or where to get that info?


#71732
May 27, 2013 17:08
Vote:
 

I think there will be a new patch available soon, however since it does not work in our Maint branch (where the patches are built from) that patch will not solve your problem. It will however be solved in next platform release (since it works in that branch).

I have reported a bug for it to be fixed in Maint as well, but when a fix will be available I cant answer.

#71733
May 27, 2013 17:13
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.