Try our conversational search powered by Generative AI!

ClientResources 404 on fresh install


After a clean installation on a web server and logging into the admin, I am presented a white page displaying only unstyled navigation.

Viewing the network inspector shows all references to the ClientResources are returning 404 errors.

This is a fresh install from the Deployment Center (EPiServer CMS 7.0.586.1). No errors were reported during install.

It is a Windows Web Server 2008 R2 server running IIS 7.5. ASP.NET 4 is installed. I have installed MVC 4 aswell. I’m running the installer logged in as an Admin. The Databases appear to be getting installed correctly. 

Am I missing something?

Jul 16, 2013 5:26

Did you install it through deployment center on that server or locally and then deployed it? Make sure the VPP paths are correct, which version of client resources are missing?


Jul 16, 2013 7:59

It was installed directly on the server using Deployment Center. ie. Not locally then deployed.

In the EPiServerFramework.config the appData basePath is set to: C:\EPiServer\VPP\MyEPiServerSite2 which is correct. Is there somewhere else the VPP path is set?

Here are the references that are returning 404's:

GET http://localhost:17000/episerver/Shell/1.0.456/ClientResources/epi/themes/legacy/ShellCore.css 404 (Not Found) episerver:7
GET http://localhost:17000/episerver/Shell/1.0.456/ClientResources/dtk/dojo/dojo.js 404 (Not Found) episerver:16
GET http://localhost:17000/episerver/Shell/1.0.456/ClientResources/epi/themes/legacy/DojoDashboardCompatibility.css 404 (Not Found) episerver:8
GET http://localhost:17000/episerver/Shell/1.0.456/ClientResources/epi/epi.js 404 (Not Found) episerver:16
GET http://localhost:17000/episerver/Shell/1.0.456/ClientResources/DojoDashboardCompatibility.js 404 (Not Found) episerver:16
Uncaught ReferenceError: require is not defined episerver:38
GET http://localhost:17000/episerver/CMS/1.0.431/ClientResources/ReportCenter/ReportCenter.js 404 (Not Found) episerver:16


Jul 16, 2013 8:13

Make sure that version of the client resources is located in your VPP folder. If it´s try deleting the temp ASP.NET files and iisreset.


Jul 16, 2013 8:31

I had a similar problem resolved here.

Jul 16, 2013 8:43


I have tried stopping iis, removing ASP.NET Temporary Files and restarting IIS and the problem is still there.

The Application Pool is running .Net Framework Version v4.0 in Integrated mode. Does this matter?

I have tried re-installing the Deployment Center on the server and doing another install and the problem persists. I have successfully installed a clean version of EPiServer doing the exact same process in my development environment so it appears to be an issue specific to the webserver I'm installing on.

Are there any other dependancies required?

Jul 16, 2013 8:44

Thanks OerjanH, I would think changing the protectedModules would be if the EPiServer dashboard was selected to be in an alternate location. In my case, the relative url during install was set to /episerver.


Edit: Also, I tried changing that setting and it didn't help.

Edited, Jul 16, 2013 8:50

I've tried re-installing Deployment Center and creating another clean install and I am still presented the same issue.

Might there be any other IIS configurations un-documented that could cause this since this prooblem appears to be server speciic?

Jul 17, 2013 1:28

I found my problem was caused by Microsoft's URLScan 3.1 ( blocking access to the client resources. 

Previously I was trying to view the installation remotely so I was not viewing the custom 404 error. When I attempted to view any of the clientresource files on the server itself I was presented with the message 404 error page stating "Rejected-by-urlscan".

To fix this I followed the instructions on this page to remove the urlscan from the EPiServer installation 

Jul 18, 2013 4:09

I had this same problem, but in my case, it was due to these two configuration lines that were left in episerverframework.config after upgrading:

<add virtualPath="~/episerver/cms/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\7.5.394.2\application\UI\EPiServer\CMS" customFileSummary="~/fileSummary.config" name="EPiServerCMS" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
<add virtualPath="~/episerver/shell/" physicalPath="C:\Program Files (x86)\EPiServer\Framework\7.0.859.1\Application\UI" customFileSummary="~/fileSummary.config" name="EPiServerShell" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />

I removed them, and then it worked.

Nov 17, 2015 12:26
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.