Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

Child page URL worked without language-ID in EPi6 - doesn't seem to work in EPi7?


In EPiServer CMS 6 we could enter the following URL and end up on the Swedish page:

If we enter the "same" URL in EPiServer CMS 7 we end up with a 404:

(the only thing that's different is 'www3' compared to 'www')

However, if we enter (notice the extra 'sv')

it works like a charm.

Can anyone explain why this is? Is it tied somehow to routing? As I see it, if it worked in EPi6 it should work in EPi7 as well.

Feb 17, 2014 16:38

Which version of CMS are you running? In some later patches a more rigid routing with respect to language where introduced (more information under

You can get more tolerant behaviour as in CMS6 by setting attibute strictLanguageRouting=false on element siteSettings in CMS7 or applicationSettings in CMS 7.5

Feb 18, 2014 10:57

Thank you for your answer, Johan!

We're running EPiServer 7.1.

I'll set strictLanguageRouting=false to see if that helps.

Feb 18, 2014 11:18

Another thing that sould be of interest for you is to setup language mappings for your hosts. You do that in admin mode under Manage WebSites. E.g. can you add a mapping for "" to "se"

Feb 18, 2014 11:21

Johan: I added the attribute strictLanguageRouting=false and added a mapping for to se, and now it seems to work.

Thank you!

Feb 20, 2014 8:47
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.