Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Scheduled job not working

Vote:
 

Hi!

I'm experiencing a strange problem regarding "Published delayed page versions". The job is set to active and is set to run every minute. But the pages that are scheduled for publish isn't published. They are if I run the job manually though.

I noticed in the database that the time set in "LastExec" and "NextExec" are two hours before the correct time. The server time is correct and the time shown in the "History" tab in the "Publish delayed page version" function is correct.
I suppose this has something to do with it.

I have googled and tried every solution suggested; restaring the service, deleting the site.xml file, emptying the scheduledItem and scheduledItemLog tables. Nothing works.

Does anybody have any idea how to fix this?

#85864
May 07, 2014 13:33
Vote:
 

Try running every scheduled job there is manually once...

Had a similar problem once and that trick solved it for me. 

#85944
May 09, 2014 8:58
Vote:
 

Tanks, but it turned out to be because of an event in global asax that I had created. I had to add the minimum access level required and set it to "noaccess":

DataFactory.Instance.Save(writablePage, EPiServer.DataAccess.SaveAction.Save, EPiServer.Security.AccessLevel.NoAccess);

#88166
Jul 03, 2014 13:13
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.