Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Trouble with autosave and publishing after upgrade

Vote:
 

Greetings!

I'm having some trouble with a site after upgrading it to Episerver 7.0.586.1.

To make sure the error is not in code, I created a new pagetype in admin mode with just 1 textfield.

Everything looks fine and I can edit pages in admin mode, the problem occurs after editing. The autosave-message says "Frakoblet, kan ikke lagre" (or "disconnected, can not save" in english). In the javascript console, an error is showing up:

[HttpException (0x80004005): Version is not writeable]
EPiServer.Cms.Shell.UI.Rest.ContentChangeManager.UpdateContentProperties(ContentReference contentReference, IDictionary`2 properties, SaveAction saveAction) +1131
EPiServer.Cms.Shell.UI.Rest.ContentDataStore.Patch(PatchContentDataModel entity) +357
lambda_method(Closure , ControllerBase , Object[] ) +127
System.Web.Mvc.ReflectedActionDescriptor.Execute(ControllerContext controllerContext, IDictionary`2 parameters) +258
System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(ControllerContext controllerContext, ActionDescriptor actionDescriptor, IDictionary`2 parameters) +39
System.Web.Mvc.<>c__DisplayClass13.<InvokeActionMethodWithFilters>b__10() +120
System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodWithFilters(ControllerContext controllerContext, IList`1 filters, ActionDescriptor actionDescriptor, IDictionary`2 parameters) +307
System.Web.Mvc.ControllerActionInvoker.InvokeAction(ControllerContext controllerContext, String actionName) +704
EPiServer.Shell.Services.Rest.RestControllerBase.ExecuteCore() +241
System.Web.Mvc.ControllerBase.Execute(RequestContext requestContext) +315
EPiServer.Shell.Services.Rest.RestHttpHandler.ProcessRequest(HttpContextBase httpContext) +274
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +913
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165

In addition to this, when i try publishing, an error pops up saying:

"The provided content link does not have a value. Parameter name: contentLink"

Thanks in advance,

Hans B.

#90929
Sep 22, 2014 15:02
Vote:
 

Hi!

If you have not already done so, I would suggest either upgrading to the latest version (EPiServer 7.5) or at least to apply the latest core update (http://world.episerver.com/Releases/Update-for-EPiServer-71-715/) and the 7.1 UI update to see if this issues are resolved in those.

#90931
Sep 22, 2014 15:09
Vote:
 

Thank you Linus for a quick response. I tried to apply the patch from the addon-section. I am having a few problems with missing text on buttons and different urls for editmode. Where does the patch install on my system when I use the addon store?

#90959
Sep 23, 2014 9:57
Vote:
 

I have narrowed the problem some:

When i edit a property, the auto-save works fine. The problem occurs when i publish. The message "The provided content link does not have a value. Parameter name: contentLink" appears, and the auto-save stops working.

#90965
Sep 23, 2014 11:51
Vote:
 

I solved it. Another project(plugin) had a pagereference setting "start page" that was not set after the upgrade process. Thank you anyway Linus :)

#90979
Sep 23, 2014 12:56
Vote:
 

Great that you solved it yourself Hans Borge. And I hope that you have a chance to upgrade to the latest version in a not too distant future :).

#90991
Sep 23, 2014 15:12
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.