Try our conversational search powered by Generative AI!

Application Monitoring tool



I am trying to install New Relic with .net application and Episever CMS 7.

But i am facing issues while installing the New Relic agent due to .net and Episever compatibility.

Please let me know if you have used New Relic ? or any other Application monitoring tool with Episerver 7

Thanks for your help


Jun 22, 2015 17:07


What specific issues are you facing? I have personally used NewRelic myself on a number of EPiServer sites (6 and 7) without any problems.

EPiServer Managed Services also uses NewRelic if you host your site with EPiServer so I am curious what your issue is?


Edited, Jun 22, 2015 20:52

Thanks for your response.

The compatibility and requirements document states it supports Umbraco and DotNetNuke

So i wanted to know if its been used before with Episerver.

However the issue i am facing while installing the .net agent is :

New Relic requires that .NET Framework 2.o/3.0 be upgraded to 3.5 prior to installation

My project uses .net 3.5 and 3.5 is already installed on the server so i am nots ure why its complaining ..

Any suggestions?

Jun 23, 2015 10:39

Is your project a CMS 6 R2 site? The system requirements for EPiServer 7 upwards are .net 4 upwards:

Can you confirm your EPiServer 7 site runs fine before installing NewRelic?

Jun 23, 2015 11:25

yes it works fine as of now, its just when i try to install the newrelic agent.. it doesnt allow due to .net version ..

Jun 23, 2015 11:33

So you have .net 3.5 and .net 4.0 installed? According to the NewRelic notes that should suffice. It may be worth double checking the .net versions you have installed?

Jun 23, 2015 11:44

I have been using New Relic with EPiServer 7 and 8 and it works great, I ran it on framework 4.0 on those days.

I am also running Microsoft Azure Application Insights with EPiServer and that also works great (even better than New Relic in some areas)

As David says, make sure that you have 4.0 installed

Jun 23, 2015 14:05

I could install the .net agent finally on my web server after i installed .net 3.5 feature in server manager..

but now i am getting the below error when i browse my site :

Could not load file or assembly 'JetBrains.Annotations, Version=, Culture=neutral, PublicKeyToken=1010a0d8d6380325' or one of its dependencies. The system cannot find the file specified. 

is thsi something to do with episerver compatibility?

thanks for your help

Jun 23, 2015 16:25

The JetBrains.Annotations assembly is associated with ReSharper and not EPiServer. Do you use ReSharper internally? 

Jun 23, 2015 16:29

yes.. we use resharper but this is happening after installing new relic, if i uninstall the new relic agent the error goes away..

Jun 23, 2015 16:38

thanks for your help

I got it working now!!

this is known issue with Episerver and NewRelic agent so i copied the the JetBrains.Annotations.dll in the bin folder and it worked!!



Jun 23, 2015 18:14

Do you have any link describing that knon issue?

Jun 23, 2015 21:38

Jun 24, 2015 10:40
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.