Try our conversational search powered by Generative AI!

Invalid DN syntax in ActiveDirectoryRoleProvider


Hi all,
I'm struggeling with getting the ActiveDirectoryRoleProvider to work at a particular site.
The webserver is using windows authentication and the ActiveDirectoryMembershipProvider too.

I can seach up users and but as soon as I try to do anything that involved groups, like click on the "Administer groups" in admin mode. I get the error as specified below. Anyone got any ideas to what could be wrong?



An invalid dn syntax has been specified.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.DirectoryServices.DirectoryServicesCOMException: An invalid dn syntax has been specified.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[DirectoryServicesCOMException (0x80072032): An invalid dn syntax has been specified.
   System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) +377678
   System.DirectoryServices.DirectoryEntry.Bind() +36
   System.DirectoryServices.DirectoryEntry.get_AdsObject() +31
   System.DirectoryServices.PropertyCollection.Contains(String propertyName) +24
   EPiServer.Security.AdsiDataFactory.CreateDirectoryDataFromDirectoryEntry(DirectoryEntry entry) +171
   EPiServer.Security.AdsiDataFactory.GetEntry(String distinguishedName) +141
   EPiServer.Security.ActiveDirectoryRoleProvider.GetAllRoles() +144
   System.Web.Security.Roles.GetAllRoles() +39
   EPiServer.Security.RoleProviderUtility.GetAllRolesWithProviders() +461
   EPiServer.UI.Admin.AdminGroup.GetAllRolesAndBind() +38
   EPiServer.UI.Admin.AdminGroup.OnLoad(EventArgs e) +263
   System.Web.UI.Control.LoadRecursive() +50
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627
Nov 10, 2009 10:27

This blog posting from Johan just totally made my day :-)

I'm thinking that this should be part of the released provider.


Nov 10, 2009 19:42

HI Morten!

Sorry for the late reply, been home with sick kids for a few days...
Glad it worked out ok for you!



Nov 11, 2009 10:10

Hope they are feeling better!

The error took me offguard a little bit as I had it all tested out in our test environment...
Then in production..boooom...
I suspect Exchange is the culprit with the schema changes it does to the AD.


Nov 11, 2009 10:15

Since Johan's article isn't available, what was the solution to this problem? I'm currently having the same problem, the same error message and call stack.

Aug 14, 2017 13:58
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.