Try our conversational search powered by Generative AI!

Cannot activate Office Add-In


I have the right permissions (as admin), and the Add-In installed properly; in edit-mode, on the "Microsoft Add-In" tab, under tab "1. Install", the button "Install version 2.2" is now dimmed down.

However, under tab "2. Activate", nothing happens when I push the Activate button.

This is a clean install - I've done nothing except installing the template site and then installing the Add-In by pushing the button on tab "1. Install".

Feb 17, 2009 9:23

If you're running on Windows Vista the activation problem is probably caused by higher security settings for IE. The activation procedure writes a registry key, but this is not allowed with the default security settings in IE on Vista and fails silently. The easiest solution is to add the site to your trusted sites zone.


Feb 17, 2009 9:42
No, I'm running XP. This was a CMS5 R2 installation. I've just tried adding http://localhost to trusted sites - with no effect. Another thing I just tried was installing the CMS5 R2 SP1 - with a new example site. Same problem there.
Feb 17, 2009 9:46

I've now also installed the new SP1 template files - and the problem is still here.

I'm running a standard installation of CMS5 R2 SP1 (with the SP1 templates) on Windows XP. I'm using Windows Internet Explorer 7.

Still no luck with the MS Add-In...

Feb 17, 2009 10:55

What url are you using (localhost or machine name)?

When you install EPiServer (version 5) the siteUrl setting will automatically be set to your machine name. You can then run your site both using localhost and value from siteUrl.

If you activate your office add-in, it will be activated for url set in siteUrl. So, if your're browsing the site using localhost (and have macine name as siteUrl), it will look as the add-in hasn't been activated.

Feb 17, 2009 12:49
Ah! Bingo! :) Changing from http://localhost to http://my-machine-name made the "Activate" button become dimmed and the "Deactivate" become active... Thanks a lot!
Feb 17, 2009 13:35

Related question (should perhaps be it's own thread?):

From MS Word, when clicking "Publish to EPiServer CMS", the dialog for connecting to my EPiServer site only lets me type the password - not the username.

How can I change the username with which to publish the document?

(E.g. suppose that I have several usernames in my EPiServer database... How can I select which user to log in as?)

Feb 17, 2009 14:06
Old post but to answer Anders Nordby... The username is the user you activated the add-in with. So in order to change which user who publish a document you need to go to Root Folder in Edit mode and "Deactivate" the Office Add-in. Log out of EPiServer and log back in with a different user and activate the Office Add-in. Voila, the user is changed.
Oct 08, 2009 12:53
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.