Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Migrated server has /en/ to Full URL, didn't exist before

Vote:
 

Hello all

Pretty new to the world of Episerver and successfully moved an installation from one hosted server to another. We had to move away from our hosting due to internal pressures.

I am running Episerver 5 SP2, the last available version on the sources page.

Basically after moving the installation I had some issues displaying pages so I added the en-GB language. However this has had the knock on affect of adding /en/ to all the websites full URL after the domain address. The server is not live yet but when I do, this is going to play havoc on our user environment. Any help to remove the link will be greatly appreciated.

Thank you all in advance.

#61074
Sep 06, 2012 10:14
Vote:
 

Compare the siteHosts element in web.config. You should have line there with language="en" or something similiar to this:

<site description="Example Site">
    <siteHosts>
         <add name="*"  language="en" />
    </siteHosts>

    

#61075
Sep 06, 2012 10:59
Vote:
 

Hello. Thanks for taking the time to reply, unfortunately there is no entry matching the section in the web.config. there already is an entry called <site description="Example Site"> which has code such as the below, but no section I can see for siteHosts. We are running IIS 7.5 would this add to the issue? If we do have to include it, how where would it feature in the web.config?

<siteSettings enableScheduler="true" stringCompressionThreshold="0"
          stringDelayedLoadThreshold="0" remoteWebServiceCulture="0" indexingDelayAfterPublish="00:00:20"
          uiDefaultPanelTab="0" indexingTextRegExp="[\p{N}\p{L}]{1}[\p{N}\p{L}-\._]*[\p{N}\p{L}]{1}"
          logServiceUrl="soap.tcp://localhost/TimeSpanAnalyzerView" uiImageTransparencyReplacement="White"
          globalErrorHandling="Off" uiSafeHtmlTags="b,i,u,br" uiOptimizeTreeForSpeed="false"
          sgmlParserDecodeCharEntities="false"

#61101
Sep 06, 2012 22:22
Vote:
 

If you're only using "en" then globalization should be turned off, and with that only "en" should be activated, and the problem will go away. If you experience some other problem when doing this, then you should solve that instead of enabling another language. :)

#61107
Sep 07, 2012 10:23
Vote:
 

1. If you don't need globalization and pages in multiple languages, ensure that all your pages are of the same language version

2. Turn globalization off. This should turn off the need for /en/ after domain name (which is EPiServers standard way of linking to a page if globalization is turn on)

If you need to have pages in multiple language versions, then I would recommend that you live with it I'm afraid.

 

#61108
Sep 07, 2012 10:29
Vote:
 

Hello, that sounds sensible and explains why the old server is set to a single language. However I now get a 404 on some websites and others work o.k. Globalization is definitely switched off.

#61109
Sep 07, 2012 10:30
Vote:
 

Need to check that all pages are in the same language then I guess so you don't have links to pages in another language (that you just disabled)

To do that you will probably want to enable globalization again and go hunting for any pages that have the "wrong" language => convert them to the correct language => delete the other language version.

#61111
Edited, Sep 07, 2012 10:33
Vote:
 

Really appreciate your time here in helping out.

Am very new to Episerver so any help in how I can do that will be great, the odd thing is on the old server just English en with the US flag was enabled similar to our new server. Looking at the site I've ensured that the country code is set to en. Wondering if it is to do with the top level page causing the lower pages to render with en-gb?

 

#61112
Sep 07, 2012 10:55
Vote:
 

Language settings for a new page is inherited from the parent page so make sure your top node is of the correct language as well. :)

#61113
Sep 07, 2012 11:00
Vote:
 

That's given me a great pointer. I've thought why do some pages work o.k. and not others? So I have created a new top level below the root (lets say its called Intraxnet) of my website and moved the content there; the websites then start working. I then deleted the old Intranet folder and created a new one, moved the content back and we are back to square 1 where the intranet pages stops working. Could something still retain the configuration for this possibly?

#61128
Sep 07, 2012 14:57
Vote:
 

Thank you so much for your help all, I believe I pinned down the issue with the valuable pointer provided. It wasn't just a language issue but in web.config there were sections for Intranet using a specific restriction module that caused the issue. Taking this out resolved the issue. Now just have to figure out how either I can restrict IP's from accessing the site or some other means of replicating what was once there.

#61133
Sep 07, 2012 15:42
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.