Try our conversational search powered by Generative AI!

EPiServerFramework installation directory was not found



I have upgraded a CMS 5 to 6 and everything seems to run smooth. But now when I’m trying to install EPiMail 5 I got:

“Error - EPiServerFramework installation directory was not found”

I have tried to repair my CMS 6 from the Deployment Center etc. I have also installed a fresh demo site and got the same error when trying to install EPi Mail 5.

Maybe this is not the right forum but someone maybe has bumped into this issue. For example:

Notice that I’m running a CMS 5 on the same machine, but they work ok together.

(sql server 2008 and win server 2008)

Any Idea and where to start?


Nov 24, 2010 0:16

Do you have the Program Files/EPiServer/Framework folder? What versions are in it?

Nov 24, 2010 7:24

Thanks Magnus for your quick reply!

I got the folder C:\Program Files\EPiServer\Framework\6.0.318.113. My CMS 6 says 6.0.530.0. Are there any other versions I should try for the framework?

Nov 24, 2010 9:00

I think I found the solution!

The installation instructions say:

 …”Run the EPiServerMail.msi file to start the installation”.

This morning I ran the .exe instead and all of a sudden there was a new folder with version Is that the correct version?



Nov 24, 2010 9:18
Vote: is the version used by the Relate 2.0 package, and perhaps by EPiServer Mail. Anyway if you now have both this should no longer be a problem and the installation should work (if that was the problem from the beginning).

Nov 24, 2010 9:20
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.