Try our conversational search powered by Generative AI!

Upgrade going wrong



We are in the stages of an upgrade from 5 R2 sp1 to version 6 which also includes episerver move to another server. The moving part goes well and i can load the site in epi 6 after the upgrade. The problem is when i try to access the editor mode i get a 404.0 error saying that "websitename/webUI/CMS doesnt exist and points to a physicalpath that is totaly wrong. Ive looked in the episerver.config and the CMS physicalpath is correct pointing to c:/program files.... but the error says the physical path is e:/location to site

Additional to this problem the update log (from the update to epi6 from 5 R2 sp1) also states alot of xform convertion errors saying some of the xform properties is missing a parent something but im suspecting that this error interfears and breaks the physicapath when the upgrades is running.

However i really need some points here in what is wrong with the physicalpath and if there is a way to point the webUI/CMS to a custom setup like prhaps webUI/mycustompath..



Feb 08, 2011 13:49

Found the problem of the mapping of physicalpath so that problem is solved. however i would appriciate if theres a way to get by the webUI/CMS thing. So instead of the CMS part i can write whatever i want and completely skip the CMS part like : webUI/edit or something like that.

by moving the folders inside the CMS folder to be in the UI folder instead and changing the different paths in episerver.config resolved the url to webUI/edit However it seems to me if i press the admin or edit button when in edit mode it redirects to webUI/CMS/edit etc so my conclusion is that its hardcoded or stored in the database. 

If there isnt anyone who could add some insights to this method i supose this thread could be marked as solved.

Edited, Feb 08, 2011 15:50
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.