SaaS CMS has officially launched! Learn more now.

EPiServer scripts disabled - how do I enable them again?



I have somehow managed to disable the context menu (both inside and outside the edit GUI) on all pages on a site I am currently developing. The site tree in the left frame also doesn't update as I click through the site in the right frame.

It has actually never worked for this site, which makes me think I made a mistake when first setting it up. Everything works as expected on the project I worked on prior to this project, so I know EPiServer is installed the propert way on my computer. It is also the same om my colleagues working on this project, so I'm pretty sure that it must be a configuration thing, either in any of the *.config files, or in the database.

All ASPX classes inherit from EPiServer.TemplatePage.

I have no idea where to start looking for the reason for this. Any hints?



Mar 09, 2011 13:02

Two things to check:

1. The VPP paths of the util files etc in web.config/episerver.config. If your episerver installation path differs from the other team members you need change the config to match your computer (it's common for example if one syste is 64-bit and has episerver files in Program Files (x86) while another is 32-bit and has them in Program Files.

2. Security of the util files etc on the web.config <location> level. This could be preventing your browser from getting the scripts from the server. BTW, use a developer toolbar and/or fiddler to see if there are any errors loading resources.

Mar 09, 2011 13:49

The paths for everything is correct (I have compared the paths in web.config and EPiServer.config from this project with the old project which worked, and they are all the same).

I have also checked the rendered results of the pages, and there are no code at all trying to fetch anything from /util/* or /episerver/* (which is where I have configured the UI to reside). It appears as though the scripts and whatever else is needed are never registered, which is what I find strange.

Mar 09, 2011 15:08

Strange... The context menu suddenly stopped working in my project too this morning. The first time I right-clicked I saw a flash of it, but now it's completely disappeared. I have the script references however, and the context menu loading function is attached using the EPi.AddEventListener method, but it is never called.

Mar 10, 2011 9:32

Nevermind, my problem was bacause of a bug in our javascript library.

Mar 10, 2011 9:59
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.