SaaS CMS has officially launched! Learn more now.

Problem upgrading to CMS 6 R2


Hi, I get this stack trace when trying the upgrade:

At C:\Program Files\EPiServer\CMS\6.1.379.0\Upgrade\System Scripts\Upgrade XForm Names.ps1:36 char:22
+ Upgrade-EPiXFormNames <<<< -SelectedSite $wizard.SelectedApplication
System.InvalidOperationException: Cannot resolve dependencies for the following module(s)
at EPiServer.Framework.Initialization.InitializationEngine.CreateDependencySortedModules(IEnumerable`1 modules)
at EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType)
at EPiServer.Framework.Initialization.InitializationModule.Initialize(HostType hostType)
at EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType)
at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.InitalizeEPiServer(String webConfigPath)
at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.Initialize(String destinationPath, String virtualDirectory)
at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.Initialize(String destinationPath, String virtualDirectory)
at EPiServer.Install.Common.AppDomains.RunInAppDomainInstaller.Install(IDictionary stateSaver)
at EPiServer.Install.InstallationManager.Install(Installer installer)
at EPiServerUpgrade.CMS6.XFormNameDecodeCmdlet.ProcessRecord()
at System.Management.Automation.Cmdlet.DoProcessRecord()
at System.Management.Automation.CommandProcessor.ProcessRecord()

Seems like it is a missing dll, but where and which? The site was started as a cms 6 so there shouldn't be any references to older stuff.



Apr 06, 2011 8:44

just a quick check, match the assemblies in bin folder and the one referenced in your web.config

Apr 06, 2011 10:09

The files match and everything is working. The update seems to have gone through. But I'm stil curious if something crucial failed.

Apr 06, 2011 11:04

Is your application .NET 4? Then you need a special setting. The step that failed is supposed to unescape data in XForms and is run after the actual upgrade, which is why the site might seem fully upgraded. I ran into this myself but had no XForms on the site so I didn't care to do the upgrade again.

More info here:

Apr 06, 2011 13:12

Thats it! I don't use xforms either so I'll skip the step too. Great to know though.

Apr 06, 2011 13:15

I'm getting the same error message, and we are in fact using XForms.  Our site is compiled against .Net 4, so I tried to run Deployment Center using 4.0 as Paul Smith suggested, but I'm still receiving the same error message about being unable to resolve dependencies.

Does anyone have any other suggestions?


Jul 01, 2011 21:28

I've received this message too, I just wanted to ask if there are repercussions of this further down the line - currently the site doesn't use xforms but it may in the future.. should I roll-back and re-upgrade?


Jul 04, 2011 11:37

We got this error when having 64-bit ImageVault assemblys in bin. We temporarily replaced them with the 32-bit DLL's during Deployment Center upgrade. The installation then went through without errors.

Oct 14, 2011 16:18

To answer Steven's question: That part of the upgrade only upgrade existing posts. If you don't have any, then don't sweat it :)

Oct 17, 2011 13:15
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.