Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

Problem with Advanced File Upload - won't work


I'm a new EPiServer CMS user (and also a sort of administrator) and just found out that there is a multiple file upload function in EPiServer CMS 6.

I use IE9 and runs it as administrator when I try to install version 2.3 of EPiServer CMS Client Components. I doesn't seems to work to install the ActiveX component. It seems to fail. But now there is a green tick beside the Advanced File Upload under Components. The two others - Spellchecker, Microsoft Office Support and Export to Excel, Microsoft Office Support - have red crosses.

But although the green tick beside Advanced File Upload above the installation button "Install version 2.3" there is a line telling me: "You are using version N/A of EPiServer Client Components".

Under the Config tab in Admin Mode i have checked the rights (under Security/Permissions for Functions) for "Allow advanced upload of files using for example drag-and-drop" and the groups Administrators and Everyone have permission. Just to be sure I added my own user account to get the permissions.

Although I have done all this I still cannot upload multiple image files to the file manager. The upload file form field just allows one file.

I checked the add-ons in IE9 where I see the CIE5Control Object. And it is activated. And the site I want to run the ActiveX on is marked as trusted site.

BUT... it seems to be a conflict in som way. The file EPiFileUpload.dll points to the folder C:/Windows/Downloaded Program Files/CONFLICT.8.

I opened the folder C:/Windows/Downloaded Program Files/ and there I found eight CONFLICT folders, CONFLICT.1, CONFLICT.2, etc... all of them containing the file EPiFileUpload.dll. The same file is also in the parent folder C:/Windows/Downloaded Program Files/.

I am running Windows 7 64 bit and IE9 (32 bit when trying the above stuff).

What have happened? Am I doing anything wrong? I am not particularly interested in manually uploading hundreds of files into the same folder on the server, one by one... :(

Aug 16, 2011 0:08

It seems there is no way to edit the my post above, so this is an supplementary question to all the above:

How does multiple file uploading in Mac OS X?

EDIT: Strange, I can edit a reply, but not the initial post.

Edited, Aug 16, 2011 9:38

Check out this post and see if it can solve your problem 

On Mac OS X there is no multiple file upload as it is a Windows only component. In order to upload multiple files using OS X you need to set up WebDav, CMS 5: CMS 6:

Aug 16, 2011 10:11

Stein-Viggo Grenersen,
thank you for your reply!

I took a look at the guide you gave me the url to and I succeeded to register the EPiFileUpload.dll (when I ran Command prompt in admin mode), but I cannot find the other DLL file, EPiOfficeIntegration.dll, on my computer's hard drive. Is EPiOfficeIntegration.dll necessary for the multiple file upload? Where do I find EPiOfficeIntegration.dll to put on my hard drive so that I can register that one too?

About the web.config file from the root of the site (I looked in Root folder under the Structure tab in Edit Mode), it seems that I don't have access to that one bacause I cannot find it anywhere. Perhaps changing in the web.config file is crucial to get the multiple file upload to work, or?

Edited, Aug 16, 2011 10:51

If you have managed to register det EPiFileUpload.dll you should be all set. Try to right click inside the filemanager and see if the option "select upload multiple files" is enabled. The other file is related to the MS Office integration where you publish pages directly from inside Word, Excel and Powerpoint. In order for this to work a web.config change as to be made - but for that ypu probably need some help from someone who knows you solution.

Aug 16, 2011 15:51

Thanks for your reply and help, Stein-Viggo!

I'll have someone to check and change the web.config file. Keep your fingers crossed that this is the problem :) 

Aug 17, 2011 11:42

Yes! it works now. Thank you Stein-Viggo!

Aug 17, 2011 14:28

I have succesfully registered the episerverfileupload.dll with regsvr32.exe. However I still canot do multiple file upload. When I rightclick inside the file manager, the "ad multiple files" option is darkened and canot be clicked. What have I missed?

Im using IE9

the problem was that I used the 64-bit version of IE......

Edited, Sep 19, 2011 11:39

For Chrome/Opera/etc users: this all seems to depend on using IE.


Apr 29, 2015 12:41
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.