Try our conversational search powered by Generative AI!

Linking to specific pages withing a PDF not working.


Hi all. Question regarding linking to PDFs from within Edit Mode.

I'm looking to link to a specific page within a PDF file using the following format:
<A HREF="">

I've added the link manually via HTML/Source view, and have tabbed back and forth noting that the link hadn't changed. Upon publishing, the link reverts to a standard link to the document and does not contain the querystring parameters that point to the page. I've even tried variations of parameter formats (.pdf?#page=4, ?page=4, &page=4) and they are reverting back to a standard link to the PDF once published.

Is there an inline solution for my content editors to use to utilize these types of links? 

Thanks for any insight!


Sep 22, 2011 22:26

I just tried it on a CMS 6 R2 installation and it worked for me. Although I used the editor and the link tool to do my link.

Is this pdf on a VPP or on an external site? 

Sep 22, 2011 22:57
Sep 22, 2011 23:04

I'm on CMS 6 R1 (I think) and it's a document in a VPP (in the default Global). 

From the editor, I tried pasting the full path plus querystring parameters as a link to a document on a different website and it saves the code properly, but does not render when the page loads after being publish. Re-editing the page and viewing the HTML shows the page reference still intact.

Is there something in the page rendering that our development partner might have used to prevent this behavior? If so, I'll need to go to them, but thought I'd check here first if there were any known issues.


Sep 22, 2011 23:20

I think there is a bug with anchor-tagsin R1 (and EPi 5). Says in the bug list that it is solved in R2.

Link to bug


Edited, Sep 23, 2011 16:43

Erik - Thank you! Yeah, I had a feeling that my version might have something to do with it and it appears that it does.

So for now, no PDF anchored links. That is untill we get updated!

Thank you all for your insight.


Sep 23, 2011 16:46
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.