Try our conversational search powered by Generative AI!

IE 11 and edit mode not working


Got an issue with IE 11 and editmode. When entering the main panel (the one with preview and edit) shrinks to about 1 cm. Checking dev tools I can see that the document mode gets set to 5. Bumping it up to edge again works for the the moment but any postback will refresh the page and set the document mode to 5 again.

Anyone else that have run into this? Is there a nice little workaround anywhere?

Dec 20, 2013 10:21

This seems to be a commonly known issue and there has been several threads about this though I havn't seen a solution (other that setting the page to older IE versions with for instance a dev tool). There is an internal investigation going on at EPiServer to see if and how the most urgent issues with CMS 6 R2 and EPiServer can be solved.

Dec 20, 2013 11:12

Cool thanks for the quick reply. 

Will ask the customer to run Chrome or FF while we wait

-edited for typos-

Edited, Dec 20, 2013 11:45

I'm still having issues with this. Every time I navigate into editmode, IE 11 goes into document mode 5. 

I have installed the fix here:

Have anyone tried this and made it work?

I'm working on an intranet if that makes any difference.

Mar 31, 2014 14:37

@Andreas: We haven't changed the document mode in that hotfix, what is the problem you are experiencing?

Apr 01, 2014 10:35

Hi Magnus.

I'm experiencing the following:

1. I go to our site i viewmode with IE11. I check with F12-developer tools, and see that the documentmode is Edge

2. I then right-click and go into editmode. I check with F12 again, and see that documentmode is now 5

3. If I ie try to insert an image in a xhtml-field, there is noe button to choose the file (thats one of the errors the hotfix should fix)

4. If I manually set the document mode to edge the button appears. 

Apr 01, 2014 10:50

Hmm.. Could it be that you have the "Display intranet sites in Comabiility View" set in the Compability View Settings and that makes IE jump to docmode 5?

Apr 01, 2014 11:20

Hi Petter

It happens even when "Display intranet sites in Comabiility View" is turned off.

Apr 01, 2014 12:15

Hmm and the site isn't listed in the same view  under sites you've added?


Apr 01, 2014 14:19


We are several that have the same problem. Please se the comments under

Is there any solution / workaround for this? Manually change the document mode does not work for me...

May 21, 2014 9:17

Hi all, I managed to find a moment to install IE11 yesterday evening. However when I logged into the site and the edit mode appeared, I noticed that the domain name had changed to random numbers and letters and the edit screen was just plain text, the 'Structure tab' was automatically refreshing every 2 seconds (worked fine in FF/Chrome).

I'm not sure if this "fix" will work for everyone and it is by no means a solution to the problem, but I went into Tools > Compatibility View Settings and added the domain to the list of websites to enable compatibility view for. The domain is not defined as trusted or intranet in IE secrity sites list. Dev Tools is still showing the site as Document Mode 5 (Default).

I hope this may help as a temporary fix for some of you, until a more permanent fix is rolled out.

May 23, 2014 11:42

Does anybody know if there is a fix for this issue yet? The latest hotfix we have installed is hotfix-6.1.379.1000 and we still have document mode 5 in IE 11 when in Edit mode. The result is that the editors have problems previewing the pages since the layout is very different/faulty when rendered in document mode 5. Changing browser settings is not an option since this particlular site has 800+ active editors.

Apr 14, 2015 11:50

We'll be submitting this issue as a bug, thank you the feedback.

Aug 20, 2015 19:24
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.