Try our conversational search powered by Generative AI!

Problems with ISAPI and CGI Restriction list settings in iis 7

I'm trying to run a CMS 5.1.422.4 site on Vista and iis 7. I've followed the installation instructions, but when I try to run the site in ISS 7 i get this error message: HTTP Error 404.2 - Not Found Description: The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server. Error Code: 0x800704ec Notification: ExecuteRequestHandler Module: IsapiModule Requested URL: http://localhost:80/ Physical Path: C:\inetpub\CMS Startersite Logon User: Anonymous Logon Method: Anonymous Handler: AboMapperCustom-37109 Most likely causes: No handler mapping for this request was found. A feature may have to be installed. The Web service extension for the requested resource is not enabled on the server. The mapping for the extension points to the incorrect location. The extension was misspelled in the browser or the Web server. What you can try: Install the feature that handles this request. For example, if you get this error for an .ASPX page, you may have to install ASP.NET via IIS setup. Verify that the Web service extension requested is enabled on the server. Open the IIS Manager and navigate to the server level. In the Features view, double-click ISAPI and CGI Restrictions to verify that the Web service extension is set to Allowed. If the extension is not in the list, click Add in the Actions pane. In the Add ISAPI and CGI Restrictions dialog box, type the path of the .dll or .exe file in the ISAPI or CGI Path box, or click Browse to navigate to the location of the file. In the Description box, type a brief description of the restriction. (Optional) Check "Allow extension path to execute" to allow the restriction to run automatically. If you do not check this option, the restriction status is Not Allowed, which is the default. You can allow the restriction later by selecting it and clicking Allow on the Actions pane. Click OK. NOTE: Make sure that this Web service extension or CGI is needed for your Web server before adding it to the list. Verify that the location of the extension is correct. Verify that the URL for the extension is spelled correctly both in the browser and the Web server. Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here. When I try to start debugging in Visual Studio i get this message: "Unable to start debugging on the web server. The web server could not find the requested resourse." EPiServer 4.61 sites run like a charm in the same Vista environment, but when i try to run my CMS 5.1.422.4 project I get in trouble. Any Ideas?
Oct 23, 2007 12:37
I had the same issue and for now I solved it temporarily by turning of the UrlRewriting: If anybody has a better solution please let me know. /René
Oct 24, 2007 10:55
I tried to turn off UrlRewriting like this: but that did not help. I suspect there is something wrong with the handle mappings, but I can't figure out what the problem is.
Oct 29, 2007 11:08
I found out what the problem was at last! There is a file called: applicationHost.config under %windir%\system32\inetsrv\config\ and in some way this file has been currupt. (The line-number ref can diff). On line 893 under section for handlers for the site episerver was installed at there are two handles added named: AboMapperCustom-62416 and AboMapperCustom-62417 and when they were added an extra backslash was added so the path to the dll-file look like this: scriptProcessor="C:\Windows\Microsoft.NET\Framework\v2.0.50727\\aspnet_isapi.dll" This makes IIS7 crash and the fix is just to take away the extra backslash so the two lines look like this: It worked for me.
Nov 15, 2007 16:39
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.