Try our conversational search powered by Generative AI!

Some Bugs in the Manager

Hello, I've tried using the Manager on Windows XP SP2 with SQL Server Express. the first thing i did was install without a database and install the templates. If i press web.config OR right click on the site and press browse in manager I receive the following error: -------------- System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values. Parameter name: site at System.Web.Configuration.WebConfigurationHost.GetConfigPaths(IConfigMapPath configMapPath, WebLevel webLevel, VirtualPath virtualPath, String site, String locationSubPath, VirtualPath& appPath, String& appSiteName, String& appSiteID, String& configPath, String& locationConfigPath) at System.Web.Configuration.WebConfigurationHost.InitForConfiguration(String& locationSubPath, String& configPath, String& locationConfigPath, IInternalConfigRoot configRoot, Object[] hostInitConfigurationParams) at System.Configuration.Configuration..ctor(String locationSubPath, Type typeConfigHost, Object[] hostInitConfigurationParams) at System.Configuration.Internal.InternalConfigConfigurationFactory.System.Configuration.Internal.IInternalConfigConfigurationFactory.Create(Type typeConfigHost, Object[] hostInitConfigurationParams) at System.Web.Configuration.WebConfigurationHost.OpenConfiguration(WebLevel webLevel, ConfigurationFileMap fileMap, VirtualPath path, String site, String locationSubPath, String server, String userName, String password, IntPtr tokenHandle) at System.Web.Configuration.WebConfigurationManager.OpenWebConfigurationImpl(WebLevel webLevel, ConfigurationFileMap fileMap, String path, String site, String locationSubPath, String server, String userName, String password, IntPtr userToken) at System.Web.Configuration.WebConfigurationManager.OpenWebConfiguration(String path, String site) at EPiServerManager.Components.SiteConfiguration.LoadConfigurationFile() at EPiServerManager.Controls.InfoPanelControls.SiteTabs.Setup() at EPiServerManager.Controls.InfoPanelControls.InfoPanelControlBase.Setup(IManagerEntity entity) at EPiServerManager.Controls.InfoPanelControls.InfoPanel.LoadControl(InfoPanelControlBase control, IManagerEntity entity) at EPiServerManager.Forms.MainForm.ShowProperties() at EPiServerManager.Forms.MainForm.MainTreeView_SelectedNodeChanged(ManagerTreeView treeView) at EPiServerManager.Controls.ManagerTreeView.MainContextMenu_MouseDown(Object sender, MouseEventArgs e) at System.Windows.Forms.Control.OnMouseDown(MouseEventArgs e) at System.Windows.Forms.TreeView.WmMouseDown(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.TreeView.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) -------------------- Most of the installation problems are related to the SQL user episerver creates in the step called "Database setup/creation" in Server i enter: localhost\sqlexpress usually the database creation goes well at this stage if i select a new database. When both progress bars for installation are complete and assemblies have been installed and the "installing config file /Web.config" shows the error which appears "Cannot install files The installation failed and rollback has been performed. (An exception occured in the onAfterInstall event handler of System.Configuration.Install.TransactedInstaller)" At this point in time considering the wording of the error I would expect the database and the database user created to be deleted again. but the database and the user are intact. I don't know if this should be considered a bug. If i go back and try creating a new database and new user, the progress bar moves to "Configuring database" and fails with the error Cannot generate SSPI Context. For me at the moment the most critical issue is the error occuring at the end of the install, and i do not know if this is caused by the fact that i run XP or perhaps that i try to install to SQL Express. but i hope somebody can shed some light on these issues.
May 04, 2007 17:42
A couple of more issues, I noticed that the webpage states that the manager is for sql 2000/2005 so perhaps my mistake in previous post trying to install on Sql Express. But the description also says that this is the standard production server installation of episerver. If i understand it correctly, it means that there will be two diffrent packages, one for developers and one for deployment? And if so, it seems a little bit strange that the example templates are deployed with the codebehind and visual studio project files. Anyways, back to the issues: In Windows 2003, i tried installing on a SQL 2000 database, and during the sql script an error occured whichsaid something like that it (the script during execution) was unable to find sys.objects. So i tried sql server 2005 instead, which worked fine. After this, i set a host header for my new site but i noticed that when browsing to this site, e.g. it tried running, which would be wrong since it omitted my custom UI path. so i appended my custom UI path and a login window appeared. I entered the credentials of my currently logged in user but nothing really happens and it seems like the installation just tries to start setup.aspx time after time and causing 404 errors because it looks in the wrong directory.
May 06, 2007 1:02
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.