VirtualPathNativeProvider shows "Page Cannot be found"


Hello everyone.

I have a weird problem with my VirtualPathNativeProvider. I have a EPiServer site on my develop machine and it has got a native provider to a folder on my computer and it works fine to both upload documents and link to these documents for users to download them. No problems.

But when I moved to our test machine the NativeProvider starts to act very weird. It works great to upload new files via the File Manager in Edit Mode and I can see (and open) the files locally on the server machine, but when I try to browse them in my browser I get a 404 0 0 error "Page cannot be found".

The thing is that the version that are on our production machine works great, no problem to browse the files in that folder, so there must be some sort of configuration on our test machine. The only thing is that I can't find out what...

I've tried given modify rights to almost every user I could think of (Network Service, the app pool account, ASPNET, even "Everyone"). I've tried to remove the folder from the disk and let EPiServer create it when I restart the app and still no luck.

Any ideas of what to test?


Mar 03, 2009 16:51

I've been testing more things now and I've found out that even if I create a new VPP with the VERSIONINGProvider, the same problem occurs. I can upload documents but I can't "browse" to them.

So it's not only the NativeProvider this affects...

Any ideas?


Mar 04, 2009 10:37

Hi Jens,

Has your problem solved? What was the fix?Because even I am facing the same issue.


S.K. SreeRaghavendra

Sep 06, 2011 10:01


Check to see if you have static files set in web.config for that path.
        <add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer" />


Sep 06, 2011 11:34

Hi Micke,

Yes I have added this into the path. But still I get  404 error.


S.K. SreeRaghavendra

Sep 06, 2011 11:40
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.