Try our conversational search powered by Generative AI!

Cannot save global functions


On a site we have recently experienced that we no longer can save a function as a global function. When you tick the checkbox, fill in the info and click save, everything apparently goes well but the function is not visible in the menu or on the template tab under composer in admin mode.

Furthermore we get a number of these in the error log around the same time we try to save a function as a global function.

EPiServer.Web.UrlRewriteModuleBase.AuthorizeRequestEventHandler - UrlRewriteModuleBase: Stripping version info from 919_5019 due to no edit-access

I have tried to google the error but came up with nothing.

Any ideas out there?

Jan 26, 2010 15:39

Hi Claus

Some questions:

  • Which version of Composer are you running?
  • Goto Administration tab in the toolbox and see if the global function you saved is there.
  • Did you able to save any global function before?
  • Goto edit mode and find out , which page has the id 919.


Jan 26, 2010 20:49

Hi Hieu

1) We are running Composer version 3.2.5

2) There are no Global Functions in the toolbox or under Composer -> Templates in Admin mode

3) Yes, and in the QA environment that should be as close to similar as possible we have no problems.

4) Page id 919 is a common content page that does not appear to be different from any other page neither in content or properties.


I have tried to comparing the web.config, the database schema, and the source without finding any other changes besides what is nessesary for running on another server.

My guess now would be that some odd dll is in the wrong version, but that is more or less like looking for a neddle in a haystack.


Jan 27, 2010 14:29

I found the problem, even though I do not know WHY it is a problem.

I had the Dropit.ComponentArt.Web.UI.dll, Dropit.Extension.dll and Dropit.Extension.UI.dll in the website/bin folder AND in the GAC. The dll's in both places were as far as I could se the same version ( for Dropit.Extension.UI.dll + Dropit.Extension.dll and 2008.1.1085.35 for Dropit.ComponentArt.Web.UI.dll).

Once I removed the dll's from the GAC and did an iisreset everything worked as a charm.

Any ideas on why there was a problem?

Jan 27, 2010 14:58

Hi Claus

Nice that you solved the problem. Composer doenst install any assembly in GAC by default so I dont know why the Composer assemblies was there :) . The dlls may have the same version number in both GAC and bin, but the file version number may differ. Could you verfiy that?

Jan 28, 2010 10:18

Sorry, I removed the GAC versions so I cannot se the file versions for those files.


Jan 28, 2010 10:25
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.