Try our conversational search powered by Generative AI!

Composer - Edit not visible


Have come across a weird issue with EPiServer 6 and Composer 4 wich seems to be somehow related to access rights settings in EPiServer/Composer. Logged on as a member of WebAdmins a can create and edit a regular text-function, but logged on as a user in WebEditor group and as a group that gives me acces to certain pages i edit mode I can create a new composer page and drag the textfunction onto the page but i can't edit or delete it.

Checking the EPiServer Composer Access-settings for the textcontrol both the WebEditors and the complementary group has Read, Create, Change and Delete settings added.

Is there something I'm missing here?

The environment is loadbalanced if that has anything to do with but since I as a WebAdmin can create and edit functions it seems that it has something to do with acces-settings configuration.

Oct 21, 2010 13:16

Solved the issue by adding Create, Change, Delete, Publish access rights on the Extension Data Container node but is this really the right way to go? The WebAdmin user does not has these these settings applied but still can create and edit functions and I think this is because they are added as Composer administrators so obviously Composer solves the issue somehow for that group.

Can someone shine some light on this or direct me to documents explaining this?

Edited, Oct 21, 2010 13:48

HI Tobias

No, you don't need to re-assign access rights on the Extension Data Container, it should be handled by Composer itself. I think your problem may depend on the issue with the cache notifying for Composer.

Composer has a known issue regarding the load balancing environment, which may cause that the changing of Composer settings (i.e. functions settings like name and access rights) in admin mode doesn't raise any cache notifying for the change in other servers.

When you re-assign the access rights for the Extension Data Container, which is used for storing all Composer settings, the system clears the cache for this page, and raised a cache notifying which force the system reload all settings again. And I thing that explains why it worked for you after chaning the access rights for the container page and not depended on which access right level it has.

Hieu Doan


Oct 21, 2010 14:23

So the solution is what? Because if I remove the access settings for the Extension Data Container the problem comes back. Is there something wrong with the loadbalancing settings in EPiServer since the change didn't seems to affect the settings.

Edited, Oct 21, 2010 14:34

Hi Tobias.

Please try to give the "Administer" access right to WebEditors for the page he/she has right to work with and try again.

Hieu Doan

Oct 21, 2010 16:18


we had the same issue in our envierment ( epi 6 + composer 4) and the soultion we tried is given administrator to the user ( on the page he need to edit) and the probelm vanished,  i think that is not a good soultion becasue now he can do some harm

Jan 10, 2011 18:56

Hi, Someone from our company deleted the WebEditors group from our EpiServer 6 R2 CMS. Can you tell me if this is a huge issue or can the Group be re-added and the users assigned back to the Group? Or will this cause a huge issue for reasons such as an ID is assigned to the group and can never be reassigned correctly? The thing that worries me is that I have to go through each Composer element on ever page of the site re-setting the permissions and there seems to be an issue where a member from the newly created WebEditors group can add a Composer element to a page and it turns grey and is unusable - only when an Administrator edits the permissions to the new control can the WebEditor add edit the control.

Aug 06, 2013 15:00
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.