Try our conversational search powered by Generative AI!

Unable to get composer to work


One of our clients is interested in EPiServer Composer. Since I've worked with it alot, I said that I could setup an EPiServer Sample Site with composer installed to let them play around a little.

But after several attempts I haven't been able to use it on my newly created EPiServer Sample.

I never get any composer functions or composer page types after installing Composer and Sample Package and if I try to create functions I get the message "Sequence contains no elements" and it won't let me create.

Anyone got any hints?

This is in Windows 7 running in VMWare Fusion.

Mar 24, 2010 16:47

Have you found a solution to this?



May 07, 2010 10:30

Hi Markus

Did you import the definitions for functions and Composer page types of the Sample template?

Take a look at the section of the  "Import page and function type definitions" in the link below.

Hieu Doan



May 07, 2010 12:48

Indeed, that solved the problem for me.

May 07, 2010 13:34

Hi there.

This post has been helpful as I installed Composer 4.0 but the instructions did not describe the import process mentioned in the link above, so thanks very much.

The problem I'm having is that I can see Composer - Edit On Page option and I can see the templates in the Content blocks and Layout blocks.  My problem is that when I click and drag the layout blocks across to the page, it doesn't do anything and won't allow me to change or add layout or content to the page.  I've checked and enabled the Rules for the Function Types as per instructions in link above.

What am I missing?

Jun 30, 2010 4:15
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.