Composer 4 javascript error


Upgraded a site to EPiServer CMS 6 + Composer 4. Now when I use composer edit on the startpage I get the following javascript error:

jQuery(this.htmlElement).droppable is not a function
Line 1
jQuery(this.htmlElement).droppable is not a function http://localhost/Dropit/Plugin/Extension/UI/Js/JQ.min.jsLine 1

Composer Edit on Page works fine on other pages so something on the startpage causes this error and worked ok with previous version of Composer. Anyaone got a clue what to look for when trying to find the error?

Jan 20, 2011 10:22

Solved it. A reference to jquery used in the sites code on the startpage caused the error. using jquery together with composer is a little jumpy. 

Jan 20, 2011 11:09

Now I get another script error but only in IE. The error occurs when clicking edit on a composer element.

Type mismatch i Dropit/plugin/extension/ui/x3.min.js.The code that generates the error is


Composer works fine in Firefox and Chrome but on Chrome there is a flash of a page can not be found (dropit/plugin/extension/ui/blank.htm) before the editpage is loaded.

Jan 21, 2011 11:24

More information about the problem. I was a bit confused that when loading Composer the composer functions was not wrapped with the correct colors for Content, Global and Layoutblocks.

Everything is white and checking the code with FireBug I see that the Containers don't get the correct Css class set.

The classnames becomes

TitleContainernull, TitleContainerBlocknull, HeadAreaLeftnull, HeadAreaRightnull. So the last value is not correct.

Perhaps this behaviour can help someone help me figure the issues we're having

Edited, Jan 24, 2011 13:29

Hi, Tobias!

I also upgrade my site from CMS 5 and Composer 3.2.5 to CMS 6 and Composer 4 and got this errors. I've just solved them out! (Mind that I did not develope my site from the scratch, got it initial from swedish Dropit)

The problem is that You probably use in solution some class (in my case it is Foundation.Extension.FunctionBase nested Dropit.Extension.Core.BaseContentFunction) that overrides!!!! renderControl method using the knowledge of realization of the Dropit.Extension.Core.BaseContentFunction.

BUT!! in 4 version this realization dramatically (in Your and my case especially dramatical) changed!!!

instead of "ft" attribute become "typename" and added attribyte "remotesite".


so, found method AddAttributesForExtension in 


 and replace to the next

protected virtual void AddAttributesForExtension()


if (IsInEditMode() && ContentFunctionData != null)


Attributes.Add("pid", ContentFunctionData.FunctionID.ToString());

Attributes.Add("wid", ContentFunctionData.WorkID.ToString());

Attributes.Add("typeid", ContentFunctionData.FunctionTypeID.ToString());

Attributes.Add("guid", ContentFunctionData.Guid.ToString());

Attributes.Add("isglobal", (ContentFunctionData.IsGlobal ? "1" : "0"));

Attributes.Add("typename", ContentFunctionData.FunctionType.ToString());

Attributes.Add("remotesite", ContentFunctionData.RemoteSite);

Attributes.Add("class", "Ext3ContentFunction");



Mar 03, 2011 16:01

thanks for the input, solved the issue. The site we used also came from Dropit.

Mar 03, 2011 16:14

You solved it earlier than I posted my solution?

Mar 03, 2011 16:20

A colleague took over this project and when i saw your response I looked up if the issue was solved and he confirmed the solution was like yours. Havent had time to followup the issue since I've been involved in other projects.

Mar 03, 2011 16:28
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.