Try our conversational search powered by Generative AI!

Login Failure


First off please excuse my ignorance if its a silly question.

I have installed Episerver for the first time to evaluate the CMS and Commerce offering.

I worked through the installation procedures as per the docs and setup the DB, CMS and Commerce.
I am currently stuck on the login page as it just keeps saying "login failed" when I use the servers administrator account credentials.
(I do NOT include the Domain or computer name in the username)

As part of the troubleshooting I have investigated and tried the following
- Tried to create another account with administrator privilages (No dice)
- Check the provider defined (I spotted this in the "Episerverframework.config" file)
<add name="Administrators" type="EPiServer.Security.WindowsAdministratorsRole, EPiServer.Framework" />
So it seems it should be trying to use a server admin account
- Check windows event log which is currently dumping the following details
Event code: 4006
Event message: Membership credential verification failed.
Event time: 3/3/2014 5:11:50 PM
Event time (UTC): 3/3/2014 6:11:50 AM
Event ID: 04a178f6ab9d4f139ba6681dc1018c0e
Event sequence: 33
Event occurrence: 3
Event detail code: 0
Application information:
    Application domain: /LM/W3SVC/35/ROOT-5-130383000315796689
    Trust level: Full
    Application Virtual Path: /
    Application Path: C:\EPiServer\ExampleEPiServerSite\wwwroot\
    Machine name: YOGI
Process information:
    Process ID: 4784
    Process name: w3wp.exe
    Account name: IIS APPPOOL\ExampleEPiServerSiteAppPool
Request information:
    Request URL: http://episerver-cms.***********/Util/login.aspx?ReturnUrl=/
    Request path: /Util/login.aspx
    User host address:
    Is authenticated: False
    Authentication Type:  
    Thread account name: IIS APPPOOL\ExampleEPiServerSiteAppPool
Name to authenticate: episerver
Custom event details:


Any suggestions will be greatly appreciated.

Mar 03, 2014 7:24

Sounds like you have problem with the membership provider you are using. I would first change the default provider to multiplex

<roleManager enabled="true" defaultProvider="MultiplexingRoleProvider" cacheRolesInCookie="true">
        <clear />
        <add name="MultiplexingRoleProvider" type="EPiServer.Security.MultiplexingRoleProvider, EPiServer" provider1="SqlServerRoleProvider" provider2="WindowsRoleProvider" providerMap1="SqlServerMembershipProvider" providerMap2="WindowsMembershipProvider" />
        <add name="SqlServerRoleProvider" connectionStringName="EPiServerDB" applicationName="EPiServerSample" type="System.Web.Security.SqlRoleProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
        <add name="WindowsRoleProvider" applicationName="EPiServerSample" type="EPiServer.Security.WindowsRoleProvider, EPiServer" />
    <membership defaultProvider="MultiplexingMembershipProvider" userIsOnlineTimeWindow="10" hashAlgorithmType="HMACSHA512">
        <clear />
        <add name="SqlServerMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="EPiServerDB" requiresQuestionAndAnswer="false" applicationName="EPiServerSample" requiresUniqueEmail="true" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" passwordStrengthRegularExpression="" />
        <add name="MultiplexingMembershipProvider" type="EPiServer.Security.MultiplexingMembershipProvider, EPiServer" provider1="SqlServerMembershipProvider" provider2="WindowsMembershipProvider" />
        <add name="WindowsMembershipProvider" type="EPiServer.Security.WindowsMembershipProvider, EPiServer" deletePrefix="BUILTIN\" searchByEmail="true" />

It also sounds like you have simular problem as this blog says:

There are a couple of things you can try


Mar 04, 2014 14:04
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.