Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

[Bug?] Not able to get RenderSettings from ContentControlBase

Vote:
 

Hi,

I have a simple local block with address data. I'm rendering the block with the property control:

<EPiServer:Property runat="server" PropertyName="VisitingAddress">
    <RenderSettings Heading="Visiting Adress" />
</EPiServer:Property>

My renderer inherits from ContentControlBase, which in turn inherits from UserControlBase which implements IRenderSettings. But the RenderSettings property is always empty! Even if I add one of the typed settings like Tag, it's still empty.

However, if I traverse the control tree up to the PropertyDataControl, I can find all the settings.

Is this is a bug? Shouldn't the renderering settings be set in ContentControlBase?

I blogged about this a while back before I knew about IRenderSettings, http://dodavinkeln.se/post/custom-rendering-settings. Then I tried to access RenderSettings in a shared block, and that worked! But it seems like it doesn't work with local blocks.

#87735
Jun 21, 2014 0:02
Vote:
 

This is a confirmed bug. Bug #117151.

#91245
Sep 30, 2014 19:06
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.