Our monthly Virtual Happy Hour is happening this week, Fri Feb 23!

Try our conversational search powered by Generative AI!

CMS Edit blank after upgrading to 7.8

Vote:
 

I have a website which worked well under EPiServer 7.5.394. Now I have updated the core and its dependencies to the latest Nuget package (which is at the time of writing 7.8.2). I followed the upgrading instructions, everything works well... except that when I access the CMS Edit functionality, the page displays the top bar, but a blank page where it was supposed to be the edit pages functionality.

Is there anyone aware of a bug like this?

Thank you

#88003
Jun 27, 2014 12:58
Vote:
 

Hi 

Have you also installed EPiServer.CMS.UI & EPiServer.CMS.UI.Core  having version 7.9.1 ? 

Do you see CMS and Shell modules under siteroot\modules\_protected ? 

#88009
Jun 27, 2014 14:51
Vote:
 

Thanks for your answer @Shahid. Yes, I see CMS and Shell folders inside modules/_protected. CMS.UI and CMS.UI.Core are also installed. And both have version 7.9.1.

#88036
Edited, Jun 30, 2014 9:21
Vote:
 

Hi!
If you open the developer console inside e.g. Chrome, do you get any javascript errors? Or do you see any 404 in the Network Tab?

If you open the episerverframework.config file, do you have any VPP mappings that points to some faulty location for the CMS UI?

/Magnus

#88040
Jun 30, 2014 11:15
Vote:
 

Hi,

I also got this problem after I tried upgrading both the CMS and Commerce (which btw failed with this error: updating 'episerver.commerce 7.5.1002.0' to 'episerver.commerce 7.9.0' failed. unable to find a version of 'episerver.commercemanager' that is compatible with 'episerver.commerce 7.9.0'.)

When I try to view the site in edit mode it doesn't load the page as David says. From the dev console I can see that dojo is trying to load Catalogs.js (http://localhost/epiui/Shell/7.6.0.0/ClientResources/epi-ecf-ui/component/Catalogs.js) but it responds with 404.

/Martin

#88044
Jun 30, 2014 14:47
Vote:
 

Hi,

It seems like the installation for the UI packages failed for some reason. Did you see anything in the package manager console when you did the upgrade?

If you go to the "old" location for the package "[appdata]\Modules\.." (not under the site\modules\_protected) do you see any folders named CMS or Shell? If they are still there try to delete them. 

When the CMS.UI package are installed using the nuget package manager we are trying to move two modules  (CMS and Shell) and tries to delete EPiServer.Suite and CMS.Sources (if they are installed)

I'm quite interested to understand why it failed for you (especially if you did not see any errors in the log).
Can you reproduce the problem? Did you have your old modules (app data) on a network share? Was the old modules folder checked in in e.g. TFS (read only)?

Or is there anything else that you can tell me about your setup.

#88048
Jun 30, 2014 15:43
Vote:
 

Hello,

@Magnus your solution worked wonders! There were the folders CMS and Shell under appdata/Modules, and once I removed them, the CMS Edit page worked! The current structure of my Modules folder is the following:

EPiServer.Commerce.AddOns.Manager
EPiServer.Commerce.AddOns.UI
EPiServer.GoogleAnalytics
EPiServer.Packaging
EPiServer.Packaging.UI
EPiServer.Suite
Google.Apis
Google.Apis.Analytics.v3
Newtonsoft.Json.Net35

Is there anything else I should consider for removal?

Thank you

#88051
Jun 30, 2014 15:53
Vote:
 

I had a similar issue, except that I was deploying my site to a production environment after installing updates on dev. I was following the instructions given on 'Applying transforms to a production environment'. I published my site from Visual Studio and performed the database transforms resulting from running Export-EPiUpdates on the development machine. I then copied the contents of the publish folder and replaced what was in the site root on the server. I also had to delete EPiServer.Cms.Shell.UI.dll and EPiServer.Shell.UI.dll from modulesbin and bin\modulesbin, but that would have happened automatically if I'd actually replaced the contents of the site instead of just copying over what was there already.

However, the instructions do not mention the required changes to the AppData\Modules folder, which is not exported when I publish the site (should it be?). To get it working I simply deleted the Modules folder on production and replaced it with the folder on dev and after that it worked. Perhaps I should have figured that out for myself, but I'd recommend updating the article for others who follow the same route as me when updating the production environment.

Rudi

#119623
Edited, Mar 31, 2015 17:52
Vote:
 
<p>I upgraded from 7.19.2 to 8.1 using nuget, after running update-epidatabase and Move-EPiserverProtectedModules in the nuget package console and removing everything from the App_Data folder I'm still not able to get the CMS edit to appear. I get the following error in the browser console:&nbsp;</p> <p>Error: uniqName_54 template:label</p> <p>at null.&lt;anonymous&gt; (http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/epi/shell/widgets.js:2:67095)<br /> at lang.hitch (http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/dojo/dojo.js:15:30903)<br /> at http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/epi/epi.js:2:40225<br /> at String.replace (native)<br /> at Object._1ef.substitute (http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/epi/epi.js:2:40039)<br /> at _21c._stringRepl (http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/epi/shell/widgets.js:2:66950)<br /> at _21c.buildRendering (http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/epi/shell/widgets.js:2:67493)<br /> at _19e (http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/dojo/dojo.js:15:39698)<br /> at _13d.buildRendering (http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/epi/shell/widgets.js:2:37414)<br /> at _68.create (http://msimarketing-upgrade.episerver.me/episerver/Shell/8.0.0.0/ClientResources/epi/shell/widgets.js:2:15497)</p>
#131530
Jul 29, 2015 16:41
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.