Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Media files gets always published

Vote:
 

Hello,

Can anyone help with the situation where Media Files (standard media from EPiServer) gets always published and do not stay "Draft".

I have the following configuration:

EPiServer.CMS                  8.0.0                Add EPiServer CMS to a web project                                                                                                                   
EPiServer.CMS.Core             8.0.0                EPiServer CMS Core Assemblies                                                                                                                        
EPiServer.CMS.UI               8.0.0                This package contains content resources, such as javascripts and css-files for the EPiServer user interface.                                         
EPiServer.CMS.UI.Core          8.0.0                This package contains the runtime assemblies for the EPiServer user interface.                                                                       
EPiServer.ContentCollaboration 1.1.0.8000           This collaboration tool enables editors to be able to collaborate with other editors real-time around content.                                       
EPiServer.Framework            8.0.0                EPiServer Framework Assemblies                                                                                                                       
EPiServer.Logging.Log4Net      1.0.0                EPiServer Logging for log4net                                                                                                                        
EPiServer.Packaging            3.2.1                Provides core components for the EPiServer Add-on store                                                                                              
EPiServer.Packaging.UI         3.2.1                Provides the user interface for the EPiServer Add-on store                

And I have explicitly **unchecked** the "Publish media files on upload" in my Settings in Admin. And media files gets always direct in published state. I cannot create draft. This is also with the image editor - if I chose to overwrite it goes directly live. And also if I upload new version of same file (with same name of course).

#118271
Mar 03, 2015 16:39
Vote:
 

Hi,

I have tried to reproduce this on the latest packages on a vanilla Alloy MVC site whitout any luck.

Could you have a look in the database to see if the flag actually has been changed? It is located in the tblSiteConfig and is called AutoPublishMediaOnUpload.

packages.config

<?xml version="1.0" encoding="utf-8"?>
<packages>
<package id="Antlr" version="3.4.1.9004" targetFramework="net45" />
<package id="Castle.Core" version="3.2.0" targetFramework="net45" />
<package id="Castle.Windsor" version="3.2.0" targetFramework="net45" />
<package id="DotNetZip" version="1.9.1.8" targetFramework="net45" />
<package id="EntityFramework" version="6.0.0" targetFramework="net45" />
<package id="EPiServer.CMS" version="8.0.0" targetFramework="net45" />
<package id="EPiServer.CMS.Core" version="8.0.0" targetFramework="net45" />
<package id="EPiServer.CMS.UI" version="8.0.0" targetFramework="net45" />
<package id="EPiServer.CMS.UI.Core" version="8.0.0" targetFramework="net45" />
<package id="EPiServer.Framework" version="8.0.0" targetFramework="net45" />
<package id="EPiServer.Logging.Log4Net" version="1.0.0" targetFramework="net45" />
<package id="EPiServer.Packaging" version="3.2.1" targetFramework="net45" />
<package id="EPiServer.Packaging.UI" version="3.2.1" targetFramework="net45" />
<package id="EPiServer.Search" version="7.7.1" targetFramework="net45" />
<package id="log4net" version="1.2.10" targetFramework="net45" />
<package id="Lucene.Net" version="3.0.3" targetFramework="net45" />
<package id="Microsoft.AspNet.Mvc" version="4.0.20710.0" targetFramework="net45" />
<package id="Microsoft.AspNet.Providers.Core" version="2.0.0" targetFramework="net45" />
<package id="Microsoft.AspNet.Razor" version="2.0.20710.0" targetFramework="net45" />
<package id="Microsoft.AspNet.Web.Optimization" version="1.1.3" targetFramework="net45" />
<package id="Microsoft.AspNet.WebPages" version="2.0.20710.0" targetFramework="net45" />
<package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net45" />
<package id="Newtonsoft.Json" version="5.0.8" targetFramework="net45" />
<package id="NuGet.Core" version="2.5.0" targetFramework="net45" />
<package id="SharpZipLib" version="0.86.0" targetFramework="net45" />
<package id="structuremap" version="2.6.4.1" targetFramework="net45" />
<package id="WebGrease" version="1.5.2" targetFramework="net45" />
</packages>

#118302
Mar 04, 2015 8:51
Vote:
 

Strange,

just tried with plain vanilla Alloy MVC site. Still media files gets directly published. No drafts. Database setting is there and has value of "False":

<?xml version="1.0" encoding="utf-8"?>
<packages>
  <package id="Antlr" version="3.4.1.9004" targetFramework="net451" />
  <package id="Castle.Core" version="3.2.0" targetFramework="net451" />
  <package id="Castle.Windsor" version="3.2.0" targetFramework="net451" />
  <package id="DotNetZip" version="1.9.1.8" targetFramework="net451" />
  <package id="EntityFramework" version="6.0.0" targetFramework="net451" />
  <package id="EPiServer.CMS" version="8.0.0" targetFramework="net451" />
  <package id="EPiServer.CMS.Core" version="8.0.0" targetFramework="net451" />
  <package id="EPiServer.CMS.UI" version="8.0.0" targetFramework="net451" />
  <package id="EPiServer.CMS.UI.Core" version="8.0.0" targetFramework="net451" />
  <package id="EPiServer.Framework" version="8.0.0" targetFramework="net451" />
  <package id="EPiServer.Logging.Log4Net" version="1.0.0" targetFramework="net451" />
  <package id="EPiServer.Packaging" version="3.2.1" targetFramework="net451" />
  <package id="EPiServer.Packaging.UI" version="3.2.1" targetFramework="net451" />
  <package id="log4net" version="1.2.10" targetFramework="net451" />
  <package id="Microsoft.AspNet.Mvc" version="4.0.20710.0" targetFramework="net451" />
  <package id="Microsoft.AspNet.Providers.Core" version="2.0.0" targetFramework="net451" />
  <package id="Microsoft.AspNet.Razor" version="2.0.20710.0" targetFramework="net451" />
  <package id="Microsoft.AspNet.Web.Optimization" version="1.1.3" targetFramework="net451" />
  <package id="Microsoft.AspNet.WebPages" version="2.0.20710.0" targetFramework="net451" />
  <package id="Microsoft.Web.Infrastructure" version="1.0.0.0" targetFramework="net451" />
  <package id="Newtonsoft.Json" version="5.0.8" targetFramework="net451" />
  <package id="NuGet.Core" version="2.5.0" targetFramework="net451" />
  <package id="structuremap" version="2.6.4.1" targetFramework="net451" />
  <package id="WebGrease" version="1.5.2" targetFramework="net451" />
</packages>

Strange ... :(

So, Magnus, you say that by your setup media files get into "draft" when you upload new file with same name to replace existing? And the change is no immediate on the published site?

#118319
Edited, Mar 04, 2015 12:09
Vote:
 

Hi,

I managed to reproduce it after a few more tries. I will report a bug and update the thread with the bug nr.

/Magnus

#118334
Mar 04, 2015 15:26
Vote:
 

This is critical and prevents to upgrade as customer is using this feature heavily.

#118341
Mar 04, 2015 15:47
Vote:
 

Thanks, Magnus!

Valdis, can you share in which version this behavior works as desired?

#118346
Edited, Mar 04, 2015 16:27
Vote:
 

7.5.19

#118347
Mar 04, 2015 16:44
Vote:
 

Here is the bug: http://world.episerver.com/support/Bug-list/bug/123209

It is expected to be part of the next EPiServer.CMS.Core release

#118571
Mar 10, 2015 11:39
Vote:
 

Hey Magnus,

thanks for updating here! I already saw the bug in the bug list. It is really cool that fix will get into next release!

#118733
Mar 12, 2015 13:39
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.