Try our conversational search powered by Generative AI!

Upgrading from 7.5 (7.13) to 9


Hi all,

I tried upgrading to the latest version of CMS. Updated the nuget packages and fixed a couple of issues in the code, such as log4net namespaces. Then set the update database flag in the config and it updated the database version. Now the site does not come up. It gives me a 500 with no explanation!

Does anybody have clues on how this can be fixed?

Anything I might have missed?

Jun 23, 2016 11:37

Log files will be your best friend...

Jun 23, 2016 11:55

Turn on log4net, check logs and event log...

Jun 23, 2016 18:22

I can see the errors in eventvwr. However, I have no idea what's wrong. Is it the DependencyResolver?

Failure while building 'Lambda: new HttpContextWrapper(HttpContext.Current)', check the inner exception for details
1.) Lambda: new HttpContextWrapper(HttpContext.Current)
2.) Instance of System.Web.HttpContextBase (System.Web.HttpContextWrapper)
3.) new ExtensibleMetadataProvider(*Default of MetadataHandlerRegistry*, *Default of LocalizationService*, *Default of HttpContextBase*)
4.) EPiServer.Shell.ObjectEditing.ExtensibleMetadataProvider
5.) Instance of EPiServer.Shell.ObjectEditing.ExtensibleMetadataProvider
6.) new ContentDataMetadataProvider(*Default of MetadataHandlerRegistry*, *Default of ServiceAccessor<IPropertyDefinitionRepository>*, *Default of ITabDefinitionRepository*, *Default of ContentTypeModelRepository*, *Default of ContentMetaDataPropertiesInjector*, *Default of IMetaDataResolver*, *Default of IContentLoader*, *Default of LocalizationService*, *Default of ExtensibleMetadataProvider*, *Default of ServiceAccessor<HttpContextBase>*)
7.) EPiServer.Cms.Shell.UI.ContentDataMetadataProvider
8.) Instance of EPiServer.Cms.Shell.UI.ContentDataMetadataProvider
9.) Container.GetInstance(EPiServer.Cms.Shell.UI.ContentDataMetadataProvider)

   at lambda_method(Closure , IBuildSession , IContext )
   at StructureMap.Building.BuildPlan.Build(IBuildSession session, IContext context) in c:\BuildAgent\work\a395dbde6b793293\src\StructureMap\Building\BuildPlan.cs:line 151
   at StructureMap.BuildSession.BuildNewInSession(Type pluginType, Instance instance) in c:\BuildAgent\work\a395dbde6b793293\src\StructureMap\BuildSession.cs:line 114
   at StructureMap.Pipeline.NulloTransientCache.Get(Type pluginType, Instance instance, IBuildSession session) in c:\BuildAgent\work\a395dbde6b793293\src\StructureMap\Pipeline\NulloTransientCache.cs:line 28
   at StructureMap.BuildSession.ResolveFromLifecycle(Type pluginType, Instance instance) in c:\BuildAgent\work\a395dbde6b793293\src\StructureMap\BuildSession.cs:line 103
   at StructureMap.SessionCache.GetObject(Type pluginType, Instance instance, ILifecycle lifecycle) in c:\BuildAgent\work\a395dbde6b793293\src\StructureMap\SessionCache.cs:line 93
   at StructureMap.SessionCache.GetDefault(Type pluginType, IPipelineGraph pipelineGraph) in c:\BuildAgent\work\a395dbde6b793293\src\StructureMap\SessionCache.cs:line 68
   at StructureMap.Container.GetInstance(Type pluginType) in c:\BuildAgent\work\a395dbde6b793293\src\StructureMap\Container.cs:line 337
   at EPiServer.ServiceLocation.StructureMapServiceLocator.DoGetInstance(Type serviceType, String key)
   at EPiServer.ServiceLocation.ServiceLocatorImplBase.GetInstance(Type serviceType, String key)

Value cannot be null.
Parameter name: httpContext
   at System.Web.HttpContextWrapper..ctor(HttpContext httpContext)
   at lambda_method(Closure , IBuildSession , IContext )
Jun 23, 2016 18:30

Nothing I recognize I'm issue I guess if none else in here has run across it before...?

Jun 23, 2016 21:27

Trying to consider if it's your templates or overall Epi that is wrong.

If you browse to /episerver/cms, are you able to access episerver?

if not, take a look at if your content types, controllers (if MVC) or views have custom code.

Jun 23, 2016 23:11

But if it was my custom code, wouldn't it raise an exception in the code? Or maybe some reference to my code?

Jun 24, 2016 11:10

I imagine it could be something when reading attributes or something. As it sometimes refer to propertydefinitions.

Thats why I was curious if it happened when browsing to your pages or if you could access the Epi UI, or even files or something that doesn't come from Epi.

Hard to troubleshoot without having access to your project so just trying to get some extra clues :)

Jun 24, 2016 11:14

Always good to check if you have any third party dlls and see if it helps to remove them. Check if you have any suspect EditorDescriptors on properties or similar. 

Other than that, start removing things and try to isolate the problem...

Edited, Jun 24, 2016 11:42
<p>Thanks everyone for the clues. It seems like you are right and BVNetwork 404 handler is the problem.&nbsp;</p>
Jun 24, 2016 13:14

Aha! :)

Jun 24, 2016 14:34

Hi I have the same error as Reza. I'm not using BVNetwork. How did you find the problem Reza and what did you do to resolve it? 



Jul 08, 2016 23:29

Check in bin folder and in references of you have any suspicious dlls that might be plugins built for earlier versions of Episerver. Remove those or try to get a newer version of them that support the latest version of Episerver.

Jul 09, 2016 4:49

I had to remove BVNetwork and add the latest one via nuget again. I can now load the site also see the login page for the edit UI. However, /episerver/cms/ returns 404. I can't see anywhere that the UI for the editor has been changed or needs to be configured differently. Does anyone have an idea what could be wrong?

Jul 11, 2016 11:15
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.