Try our conversational search powered by Generative AI!

Issues with VPP migration tool


VPP Migration from version 7.5 to version 8 was successfull by using the steps in .When I upgrade the same solution to version 11.13.2 from 8 the images are not visible.

When this did not worked I tried to use VPP tool for version 11.13.2 ,it generates the following error.
Could not load type 'EPiServer.Web.Hosting.IHostingEnvironment' from assembly 'EPiServer.Framework, Version=, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.

Dec 16, 2019 9:17

Hello! You are missing the right version of EPiServer.Framework.AspNet.dll

Dec 16, 2019 10:18

Hi Gosso,

Thanks for the reply . I have  EPiServer.Framework.AspNet.dll in version 11.13.2. Should I upgrade this to 11.14.0 or use some other version?

Edited, Dec 16, 2019 10:43

Please supply us the context.

If you are upgrading from 7.5 to 11, the concept might be that you need to run the migration tool in version 8 or 9, before upgrading to 11. The upgrading needs to be done in steps. from 7,5 to 8, then to 9, then to 11. Something like that.

Dec 16, 2019 10:48

Hi Gosso,

I have upgraded the solution from version 8 to 9.Now when I use this in VPP tool ,it generates error "Could not load type 'EPiServer.Web.Hosting.VirtualPathHandler' from assembly 'EPiServer, Version=, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.

Dec 17, 2019 13:13

Why dont you run the VPP migration tool in v8 where it works, and then continue the upgrade from there. This is Tricky =) 

Dec 17, 2019 14:16

I did that but after the upgrade images are not visible on the screen. 

Dec 17, 2019 14:38

this should work, maybe something other is wrong, the routing. So VPP migration tool i working in v8. then you upgrade more... whats the url to an image in v8, what is it in v11? whats the error? 404? is the image working in backend episerver?

Dec 17, 2019 14:55

The image url in version 8 is "/Global/Nets/News-Articles/Defaults/Logo_Empty_Image_Filler.png" and for version 11 is "/link/a85198b5d7ef4013bd1197905b83cbb1.png".The media folder in EPiserver for Version 11 is empty and the error for image is "Failed to load resource: the server responded with a status of 404 (Not Found)"

Dec 18, 2019 7:30

Soo, there is some you could do... 

add classic route if it is not in RouteTable allready:
routes.Insert(0, ServiceLocator.Current.GetInstance<EPiServer.Web.Routing.ClassicLinkRoute>());

check if a85198b5d7ef4013bd1197905b83cbb1 exists in blob directory

use UrlResolver.Current.GetUrl(link) to get the friendly url. 

if you upload an image in v11, does the url start with /global/ 

Dec 18, 2019 8:22


Url  starts with /globalassets/xxxx.png when a image is uploaded in v11 and a85198b5d7ef4013bd1197905b83cbb1 does not  exists in blob directory.

I am using ASP.NET web form application. So should i add the classic route mentioned above in Application_Start of Global class.

Dec 19, 2019 8:27
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.