Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Issues enabling EPiServer search in an existing website. Azure

Vote:
 

Hi all,
I'm enabling EPiServer search in an existing website.
After setting it up and verifying that it works as expected in localhost, when I deploy to Azure it doesn't.

I've configured the web.config file in Azure to point to the correct domain when indexing like so:

    <episerver.search active="true">
        <namedIndexingServices defaultService="serviceName">
            <services>
                <add name="serviceName" baseUri="http://www.correctdomain.com/IndexingService/IndexingService.svc" accessKey="local" />
            </services>
        </namedIndexingServices>
        <searchResultFilter defaultInclude="true">
            <providers />
        </searchResultFilter>
    </episerver.search>
    <episerver.search.indexingservice>
        <clients>
            <add name="local" description="local" allowLocal="true" readonly="false" />
        </clients>
        <namedIndexes defaultIndex="default">
            <indexes>
                <add name="default" directoryPath="[appDataPath]\Index" readonly="false" />
            </indexes>
        </namedIndexes>
    </episerver.search.indexingservice>


After running the index job on the site, no Index folder and no index is created in my Azure filesystem.
When trying to search on the edit interface above the site tree, no results are found as you'd expect.

Am I missing something to make this work?

Kind Regards,
Otavio

#228367
Sep 24, 2020 8:13
Vote:
 

Maybe the [appDataPath] cannot be found/is not set?

#228372
Sep 24, 2020 11:25
Vote:
 

Thanks Jeroen, I've checked App_Data exists using "AppService Editor", then manually created the "Index" child folder and tried a few values with no success:

1 - App_Data\Index

2 - \App_Data\Index

3 - ~App_Data\Index

4 - ~\App_Data\Index

Looking at the logs, I found 404s when it looks for "IndexingService.svc". Strangelly the domain name I set on web.config was replaced with the Azure default AppService one... 

azureappservicedomain:80/IndexingService/IndexingService.svc/update/?accesskey=local

Still no luck

#228422
Edited, Sep 25, 2020 13:26
Vote:
 

Hi Otavio

First of all, for cloud sites the official recommendation is to use Episerver Find instead of Episerver Search. But if you have only 1 web app instance, or if you make a dedicated indexing/search instance, you can proceed anyway.

Have you found any clues from the logs? Or tried connecting directly to the URL.

It could be that you need to change the baseUrl to a HTTPS URL in production.

#228428
Sep 25, 2020 17:29
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.