Try our conversational search powered by Generative AI!

EPiserver.Url property cannot handle campaigns/promotions after upgrade?



We upgraded from CMS 11.15 to 11.20.4 and from this version I cannot drag-n-drop a camapign or promition into a EPiServer.Url property.
Is this a bug or something that changed on purpose?

EPiServer.UI was upgraded from 11.24.1 to 11.32.1

We have a page where I have a couple of Url properties and the are popoulated with a link to a promotion. After upgrade I was trying to change the value of the property but that does not work. The dialog does not let me link to a promotion or campaign but it could be done using drag-n-drop but after upgrade that is not possible any more.

I have tried to look into the release notes but I cannot find anything about this, what has happened?



Mar 24, 2021 8:06

How is your Url property defined? Does it have any attribute decorated? 

Mar 24, 2021 9:11


No attributes, only standard declaration:

    Name = "Url if user has free products",
    GroupName = SiteTabs.FreeCampaign,
    Order = 20)]
public virtual Url HasProductUrl { get; set; }
Edited, Mar 24, 2021 9:18

Do you have controller to your promotion/campaign? i.e. can visitors visit a campaign/promotion page? If not, I think that is the problem. 

Mar 24, 2021 12:36

Ok, but the code has not changed except for the upgrade and before I could drag-n-drop a promotion.
What you are saying is that the EPiserver.Url property is so smart that you cannot drag-n-drop items that not have a controller? Sounds a bit to complicated for me?

Mar 24, 2021 12:43

I'm not 100% sure but it sounds like you could do that before as a defect/overlook, and that is now fixed.

Why would you want to store the Url? Can a ContentReference be used instead? 

Mar 24, 2021 12:54

And the requirement is "Route-able", i.e. there is an Url that you can access the content. The simplest way to do that is to have a controller that can handle the content (i.e. a "template"). It does not specifically check for controller, btw. 

Mar 24, 2021 13:39

Sure, there are many possible way to handle it but it has worked before and you get a little confused when the function is not there anymore.

Thanks for your help!

Mar 24, 2021 14:06
Quan Mai - Mar 24, 2021 14:09
yeah it can feel strange when something worked before stopped working :). It is not a feature, it was a bug ;)
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.